I installed lxde & kde (along with konsole). now I launch xterm from a Windows host using Xlaunch(Xming) which works fine but when I want to launch konsole(my preferred shell) I get this error:

:~$ konsole
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
unnamed app(4284): KUniqueApplication: Cannot find the D-Bus session server:  "Failed to connect to socket /tmp/dbus-aGE9cG1V4s: Connection refused" 

unnamed app(4283): KUniqueApplication: Pipe closed unexpectedly.

How Can I solve this?

I can launch startkde from Xlaunch and start Konsole within KDE just fine, why does it not launch from xterm (without KDE running in the same screen I guess)?


I was receiving the same message Cannot find the D-Bus session server but for a different reason.

The missing socket it was complaining about was actually being exported from my shell:


All I had to do was clear that variable (from all my shells) and try again:

| improve this answer | |

As suggested in a comment, Why can't I run Gnome apps over remote SSH session? is a similar issue, similar cause. When you try to run konsole, it attempts to make a connection to the remote D-Bus server, and fails (because that is not running).

As for the warning messages, those are known, and associated with long-term problems in KDE which have apparently not been dealt with (other than suggesting that modifications be made to konsole to quiet some of the messages).

Further reading (several of the comments in the bug reports dispute the developers' assertions that the warning can be ignored):

| improve this answer | |

I've figured it out, it'll work fine if I launch konsole with dbus-launch konsole like als suggested in this post:Why can't I run Gnome apps over remote SSH session?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.