0

On Gnome, using Tweak Tool under typing, I set the numeric keypad keys on my laptop to work as numbers only on pressing Fn + key not when I turn the numlock on. See below. I use it mainly in Libreoffice to set the styles with Ctrl + Fn + 1 for Header 1, etc. At present on XFCE pressing

  • Ctrl + Fn + 1 (physical key j) is interpreted as the "End" key.
  • Ctrl + Shift + Fn + 1 gives nothing
  • but Shift + Fn + 1 gives "1".

enter image description here This is because my laptop does not have a proper keypad. The numeric keypad uses the normal letter keys on the right.

How do I achieve the same effect on XFCE? Is there a way to make XFCE use Ctrl + Fn + Num combinations?

  • 1
    As far as I know the Fn key is not serviced by the OS - it is implemented in hardware, so I am surprised that you have it working with Gnome and not working with XFCE – Serge Jan 27 '16 at 19:45
  • The Gnome XKB setting was with the Numlock key not the Fn keys. – To Do Jan 27 '16 at 21:25
  • How did you do it in Gnome? The underlying mechanism doesn't depend on the desktop environment. If there's a Gnome user interface for it, figure out what command (probably XKB-related) it emits under the hood, and call that. If you need help figuring it out, tell us how you did it in Gnome. – Gilles Jan 27 '16 at 22:44
  • In the Question body you use Fn + Num and Fn + key (singular) .in the comment above Fn keys (plural). Could you be more specific, please – Serge Jan 27 '16 at 22:46
  • Added an image to clarify how I achieved the right configuration. – To Do Jan 29 '16 at 19:38
0

I found the answer myself with the help of another similar answer.

Go to Settings, Settings Editor, keyboard-layout and under XkbOptions, I added numpad:microsoft to the Group string.

Now it's working as it used to do in Gnome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.