0

How can I stop Linux from doing a fake Restart Computer when I go to select Restart from the Quit menu.

What I mean by a fake restart is that, it goes to do a restart, shows the splash screen image in my case Linux Mint splash screen, wait a few moments, then the screen turns glitchy pixelated fuzzy noise for split second, blanks, then goes back to the splash screen and returning me to the login screen again.

What should be happening:

Select Quit from the menu, select Reboot, the computer reboots normally showing post boot screen before starting to boot into the OS.

I'm not too sure if this was the result from installing certain packages which handles how the computer should reboot, but I'm unsure, since I don't recall installing something like that, but possibly installed along with something else which is taking over the normal reboot process. I have no idea what package name or what package in particular would be the cause.

1

This sounds like your mint installation has kexec installed.

kexec is a system call which tells the kernel to load another kernel image, and to jump to its entry point. That new kernel will then replace the old kernel, and initialize the hardware. In essence, it is a reboot, except that you don't get through the firmware (the "BIOS"), which makes the reboot go faster.

If you don't want that for some reason (e.g., you need to change some firmware settings), you have two options:

  1. Do a cold boot (power off, then power on again)
  2. Remove the kexec-tools package.
  • Oh that package huh? I don't remember what I installed to even get that at the time. – user91679 Jan 27 '16 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy