1

I am trying to install Arch Linux on an encrypted partition (LVM on LUKS). I followed the relevant Arch Wiki guide, but when I do:

grub-install --recheck /dev/sda

it gives me this output:

grub-install: error: failed to get canonical path of 'airootfs`

Then I tried to do:

arch-chroot /mnt /bin/bash
grub-install --recheck /dev/sda

And it gives me this output:

grub-install: warning: Attempting to install GRUB to a disk with multiple partition labels. This is not supported yet..
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using bloclists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists

I tried to follow the bootloader page on the wiki, but I don't understand what I have to do very well. Below is a screenshot showing the output of lsblk (I can't copy/paste because I don't want to shut down my machine during installation):

lsblk output

I think the loop0 was created when I did grub-install --recheck /dev/sda but I am not sure about this.

  • you'd do better to uninstall grub – mikeserv Jan 26 '16 at 15:12
  • Indeed you should change root before installing GRUB. Also are you installing on EFI mode or legacy mode? If possible, post the exact commands you are typing in your setup process (yes, all of them). Please ping me with the @Marc.2377 notation if you do – Marc.2377 May 29 '17 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.