7

I'm having CentOS 7 64 installed on my desktop. After recent system update, I am getting below error while booting the CentOS 7.

Some time system is able to boot and I can work on it. but it gives the same error at the time of next boot.

after entering this:

systemctl status kdump.service

I get this:

● kdump.service - Crash recovery kernel arming
Loaded: loaded (/usr/lib/systemd/system/kdump.service; enabled)
Active: failed (Result: exit-code) since Thu 2015-01-22 02:55:49 MST; 39min ago Main PID: 1139 (code=exited, status=1/FAILURE)

Jan 22 02:55:49 localhost.localdomain kdumpctl[1139]: No memory reserved for crash kernel.
Jan 22 02:55:49 localhost.localdomain kdumpctl[1139]: Starting kdump: [FAILED]
Jan 22 02:55:49 localhost.localdomain systemd1: kdump.service: main process exited, code=exited, status=1/FAILURE
Jan 22 02:55:49 localhost.localdomain systemd1: Failed to start Crash recovery kernel arming.
Jan 22 02:55:49 localhost.localdomain systemd1: Unit kdump.service entered failed state.
Jan 22 02:55:49 localhost.localdomain systemd1: kdump.service failed.

system-config-kdump:
command not found...

Adding image

enter image description here

3

Install the required packages

yum --enablerepo=debug install kexec-tools crash kernel-debug kernel-debuginfo-`uname -r`

Modify grub

A kernel argument must be added to /etc/grub.conf to enable kdump. It’s called crashkernel and it can be either auto or set as a predefined value e.g. 128M, 256M, 512M etc.

The line will look similar to the following:

GRUB_CMDLINE_LINUX="rd.lvm.lv=rhel/swap crashkernel=auto rd.lvm.lv=rhel/root rhgb quiet"

Change the value of the crashkernel=auto to crashkernel=128 or crashkernel=256 ...

Regenerate grub configuration:

grub2-mkconfig -o /boot/grub2/grub.cfg

On a system with UEFI firmware, execute the following instead:

grub2-mkconfig -o /boot/efi/EFI/Centos/grub.cfg

Open the /etc/zipl.conf configuration file

locate the parameters= section, and edit the crashkernel= parameter (or add it if not present). For example, to reserve 128 MB of memory, use the following:crashkernel=128M save and exit

Regenerate the zipl configuration:zipl

⁠Enabling the Service

To start the kdump daemon at boot time, type the following command as root:

chkconfig kdump on

This will enable the service for runlevels 2, 3, 4, and 5. Similarly, typing chkconfig kdump off will disable it for all runlevels.

To start the service in the current session, use the following command as root:

service kdump start
  • GAD3R not working, edited the question with the current error. – Mongrel Mar 11 '16 at 4:03
  • Change it to crashkernel=256M@256M – GAD3R Mar 11 '16 at 19:10
  • I have tried it till 512 MB still not Woking – Mongrel Mar 12 '16 at 13:32
1

You can check seven line,they show you No memory reserved for crash kernel.It's means you need edit grub file ,give crash kernel some space,usually 128 or 256.

  • I given 512 but it is unable to refer that and again gives me the error. this error is occurred approx 2 time every 10 reboot. – Mongrel Jun 15 '16 at 11:53
  • Maybe it's because 512 don't enough to store core file. You edit grub file like "crashkernel=512" or "crashkernel=512M"? It should be "crashkernel=512M". – wenshizhang Jun 17 '16 at 1:37
  • Its is set to 512M Previous was set to 128M – Mongrel Jun 17 '16 at 3:04
0

This message is pretty google-able:

Jan 22 02:55:49 localhost.localdomain kdumpctl[1139]: No memory reserved for crash kernel.

The discussion on the first link on google recommends to use

system-config-kdump

Or just add crashkernel=128M to the GRUB_CMDLINE_LINUX variable in /etc/default/grub and run grub2-mkconfig -o /boot/grub2/grub.cfg, as proposed in the other guide.

I don't have CentOS 7 around here to try, but I believe you will be able to sort that out with this information.

  • Jakuje I have tried this but no luck. still it gives the same error. – Mongrel Mar 10 '16 at 12:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.