0

I caused the bug but I would like to fix it without doing the amateur "fresh" install.

HOW: I copied a bunch of commands and ran them.

OS: Debian 8

When I run Iceweasel the following services crash the browser

  • gmail

  • facebook

Additionally my browser crashes after I input words of a certain length into the search bar, the issue won't reproduce today and I haven't saved any logs.

espo@EVA-00:~$ sudo iceweasel
[sudo] password for espo:

(process:2060): GLib-CRITICAL **: g_slice_set_config: assertion >'sys_page_size == 0' failed
console.error:
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node
console.error:
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node

(gst-plugin-scanner:2146): GStreamer-CRITICAL **: gst_structure_new_empty: >assertion 'gst_structure_validate_name (name)' failed
espo@EVA-00:~$ sudo iceweasel

(process:2161): GLib-CRITICAL **: g_slice_set_config: assertion >'sys_page_size == 0' failed
console.error:
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node
console.error:
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15030:21
espo@EVA-00:~$ iceweasel

(process:2256): GLib-CRITICAL **: g_slice_set_config: assertion >'sys_page_size == 0' failed

My Issue with apt-get is more straightforward.

espo@EVA-00:~$ sudo apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. 
This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 1:2.2.1-dmo12) but it is not going to be installed
       Depends: libavcodec56 (>= 10:2.8.4) but 6:11.4-1~deb8u1 is to be installed
       Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is to be installed
       Depends: libvlccore8 but it is not going to be installed
       Depends: libvncclient1 (>= 0.9.10) but it is not installable
       Recommends: vlc-plugin-notify (= 1:2.2.1-dmo12) but it is not going >to be installed
E: Unable to correct problems, you have held broken packages.
espo@EVA-00:~$ 
0

Apt complains about held broken packages, so start with

$ dpkg --get-selections | grep hold$

and remove the held status from each PACKAGE in the resulting list with

$ echo PACKAGE install | sudo dpkg --set-selections

Then try

$ sudo apt-get install -f

If there are too many broken packages

$ sudo apt-get install -f --ignore-hold

may be quicker, but I don't know whether the held status will be kept afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.