3

I recently recompiled my kernel to support the vesa framebuffer for some Directfb fun but now my console outputs text very slowly. It's almost as if turning on the framebuffer caused my console to stop using whatever graphics driver it was before and instead output using the fb. I've searched all around my system for various tty or console configuration files with no prevail.

2

You would do this in the grub configuration (requires a reboot to apply the changes).

Further reading:

  • Well I don't necessarily want to disable the framebuffer. I would still like to use it for programming purposes but I would like the console to output using something other than the framebuffer. – user3211355 Jan 25 '16 at 12:07
  • @user3211355 sort of unrelated, but what are you using framebuffer for to program ? – Panther Jan 25 '16 at 12:32
  • Just for my own curiosity really. I'm in the process of exploring and trying to learn the low level aspects of linux. – user3211355 Jan 25 '16 at 15:38
  • If you want to do that, you're better off setting up two machines, and using ssh to connect into your experimental machine. – Thomas Dickey Jan 25 '16 at 15:50
0

I wanted to do exactly the same as user3211355: leave the framebuffer enabled, but just don't have the console output going into it.

Took me quite a while, but found it in the end: fbcon was modprobed somewhere. Removing that fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.