I have created a bootable usb with the latest Kali version (2016.1), and it works.

In the boot menu (see gif below) if I choose Live (amd64) or Live(amd64 failsafe) it starts doing something but then it takes me back to the same menu. No way to get it started. Any suggestions?

EDIT: System info: Asus N550JK Notebook, where I have windows 8 and ubuntu 14.04 in dual boot (ubuntu was installed from a bootable usb key).

EDIT2 : Got the message that cannot be seen on the gif:

Booting kernel failed: Invalid argument

enter image description here

  • And what's that 'something'? Does it have any output?
    – TNW
    Commented Jan 24, 2016 at 18:32
  • That bootscreen looks a lot like kali 1.x. Where did you download the iso? What computer are you running it on?
    – redfast00
    Commented Jan 24, 2016 at 22:33
  • The screen is taken from the internet ,it's not the one I'm seeing.downloaded from Kali website and running on an asus n550jk notebook
    – MQ87
    Commented Jan 24, 2016 at 22:41
  • @TNW The output is very fast I can't read
    – MQ87
    Commented Jan 24, 2016 at 22:44
  • Just to exclude the simplest problem: What CPU your PC is running?
    – Serge
    Commented Jan 25, 2016 at 1:42

4 Answers 4


I ran into this same problem and I fixed it by using parted to change the filesystem label from msdos to gpt.

Open your USB flash drive with parted:

sudo parted /dev/sdX

Use the print command to see what the current filesystem label is. This is what I get:

GNU Parted 3.2
Using /dev/sdh
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print                                                                
Model: SanDisk U3 Cruzer Micro (scsi)
Disk /dev/sdh: 2048MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  2048MB  2047MB  primary  fat32        boot

Notice the partition table is MSDOS. When you use dd to write the ISO to your flash drive, it does not appear to write a partition table with it so you are stuck with whatever format it had before. Anyway, use the mklabel command to change the label from msdos to gpt.

(parted) mklabel gpt
Warning: The existing disk label on /dev/sdh will be destroyed and all data on this disk will be lost. Do you want to continue?
Yes/No? yes   

Now use dd to write the ISO to your flash drive and it should boot. At least this worked for me, YMMV.

  • For me command mklabel gpt in interactive mode of parted doesn't work. German error message is: Fehler: Das Argument ist ungültig, während /dev/sdb zum Schreiben positioniert wurde. I used this command instead: [root@sirius ~]# parted /dev/sdX mklabel gpt Commented Mar 8, 2017 at 8:07

the problem in the way you created your live usb !

no doubte you used unetbootin or any other simillar ,

remember for Kali-linux creat your live usb using dd

sudo dd if=/path/to/kali*.iso of=/dev/sdX

where sdX is your usb (sda, sdb ...) NOT a part like /dev/sdX1 !

  • Nothing to do, done as you said,same issue. This time i was able to get the error message: Booting kernel failed: Invalid argument
    – MQ87
    Commented Feb 5, 2016 at 20:48
  • since kali 1.6 to kali 2.0 sana , i know that kali-linux doesn't work well on a usb even if it work , you won't be able to do any in partitionning step , but when i creat my usb using DD program , i wasn't able to encounter any problem ! and here we have last kali distro which i haven't try yet :)
    – Yunus
    Commented Feb 5, 2016 at 21:21
  • please try the light iso image , or better install kali 2.0 sana , because last distro still new, which means it will contain a lot of bugs ...
    – Yunus
    Commented Feb 5, 2016 at 21:25

Your live USB might be corrupt. You might want to try to recreate your live USB using either Win32DiskImager on Windows or with dd on your Ubuntu install.

  • actually it was made with Win32DiskImager, I will try with dd option
    – MQ87
    Commented Feb 5, 2016 at 12:04
  1. If you make a usb boot from Windows using rufus, please use dd way to write your iso file to the usb as younes said.
  2. No need to enable legacy boot. I use thinkpad x220 and still get UEFI on boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .