2

This question is an exact duplicate of:

I know that specifics are what get answers, but unfortunately here's where I'm at. I don't fully understand how the linux system works and operates. I do enjoy it because I feel like there are so many options. I get a lot more control over what I do/can do vs when on a windows machine.

I can't get any audio on my distro since upgrading. Before the update, I had the option to raise and lower my volume, but now the option is gone or incomplete looking. In the gui for the audio settings, it does not list anything as an output option. My laptop's soundcard isn't listed, my earphones/headphones don't show up when I'm plugged in, and I can't plug into speakers to get any audio. Does anyone know the next step?

I've tried a few different things people have recommended online with no avail, and I don't remember the different things I tried exactly, so if you give me options, even if I've already tried it, it'll be very appreciated. When I run Kali live, it DOES have audio so I know I messed up my system somehow. I just don't know how to figure out where I went wrong exactly because there were 400 updates available.

(I've edited this to include the list of my sources that were used to update/upgrade my distro)

enter image description here

marked as duplicate by Rui F Ribeiro, RalfFriedl, elbarna, schily, X Tian Nov 16 '18 at 15:17

This question was marked as an exact duplicate of an existing question.

  • When you say 'updated', I take it you mean sudo apt-get update && sudo apt-get upgrade? – cremefraiche Jan 24 '16 at 9:59
  • That is correct. I should've at least mentioned that, sorry – Sani Evans Jan 24 '16 at 10:03
  • Did you edit your sources.list? – redfast00 Jan 24 '16 at 11:16
  • Can you give me the output of ` arecord -l` and record -L? – redfast00 Jan 24 '16 at 11:30
  • Sure thing, here you go. – Sani Evans Jan 24 '16 at 21:42
2

This is what worked for me, I had this issues in Kali 2016.2. Found it in cybrary.it

  1. Open Terminal

  2. Copy and Paste this command

    systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    
  3. You may need to reboot

1

first of all : run this commands:
1) lpsci , to get the name of your audio device
2) apt-get install libasound2 alsa-utils alsa-oss
3) alsamixer
At this stage your terminal will look like a dj mixer.
Press F6 to select your sound card.
If there is a colonne where it's marked MM (which means mute) navigate to it (directions buttons) and press M (to unmute).
Now if it's marked 0 so press up arrow to increase it

Not the answer you're looking for? Browse other questions tagged or ask your own question.