during early boot, I get following error message:

[sdb] No Caching mode page found
[sdb] Assuming drive cache: write through

If I understand correctly, this is actually just a harmless info message and not an actual error. sdb is my USB disk, and it does not use caching .

The problem is, I have intentionally set kernel loglevel to 4, to get rid of these kind of useless info messages.

Why then do I still get this info message?

The reason why it's bothering me is, that it interferes with my password prompt (for decrypting my LUKS disk)

Is there a way to get rid of this message ?

  • Use a lower kernel parameter eg loglevel=0 to tailor linux messaging levels. I think level 4 is too high to silence this specific message. Level 0 is probably too drastic, but it does get rid of ALL annoying system puke in the middle of my sweet, sweet boot screens. – Dominic Cerisano Jul 6 '17 at 21:49

Hard disks have a small amount of RAM cache to speed up write operations. The system can write a chunk of data to the disk cache without actually waiting for it to be written to the disk. This is sometimes called "write-back" mode. If there is no cache on the disk, data is directly written to it in "write-through" mode. The Asking for cache data failed warning usually occurs with devices such as USB flash drives, USB card readers, etc. which present themselves as SCSI devices to the system (sdX), but have no cache. The system asks the device: "Do you have a cache?" and gets no response. So it assumes there is no cache and puts it in "write-through" mode.

You may try to go to:

/etc/modules

and on top of the modules list add the line

usb_storage

It should look something like this:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

usb_storage
lp

This is how I solved a similar problem.

Let me know what happened.

  • 1
    I am not sure what problem this is supposed to solve. But it is not applicable to my problem. Besides, I don't use modules in my kernel. – Martin Vegter Feb 9 '16 at 12:31
  • It did not fix it – aeid Jul 27 '17 at 16:22

Yes. You can get rid of such messages by executing following command:

echo 0 > /proc/sys/kernel/printk

This will suppress almost all the kernel messages and will display only Emergency messages

See this link for more info

  • Why downvote ??? – SHW Jan 28 '16 at 9:54
  • 2
    Probably because this will not have effect during early bootup, before any userspace takes control. Same setting will have effect by adding loglevel=0 to kernel command line from bootloader (by editing and applying bootloader configuration before next reboot). P.S. I did not down voted, just FYI. – user140866 Jan 29 '16 at 5:16
  • I mean under userspace control is that echo command that does write to /proc/sys/kernel/printk pseudofile. – user140866 Jan 29 '16 at 5:18
  • OP can add above echo command in his one of initramfsfs hooks or scripts. – SHW Jan 29 '16 at 9:25
  • 1
    @SHW - I don't want to suppress all kernel messages. My question is explicitly "how can I get rid of this message". Besides, I stated in my original post that I am using kernel parameter loglevel=4. I could just change that to loglevel=5 to get rid of almost all messages, but this is not what I want. – Martin Vegter Feb 9 '16 at 12:28

This is probably a warn message (maybe the driver considers it important enough to mention). You did not specify which driver your USB hard drive is using so I can't point to the source line to verify this. More info on log levels here: http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/include/linux/kern_levels.h?id=HEAD

The easiest fix would be adding "quiet" to your kernel arguments via the bootloader, whether it's GRUB/LILO/etc.

Change your usb boot method while changing the usb as a bootable device use power iso tool to make your usb bootable device it'll work 100% with out fail ...

I had this problem with a new Arch Linux UEFI installation where I was using a UEFI Live USB to load the bootloader on the ESP.

The solution was to fix the setup with an EFI Boot Manager.

If you use GRUB & not an EFISTUB to boot Linux you do NOT need to add any crypt kernel commands to the efibootmgr commands.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.