2

I have installed FreeBSD 10.2-RELEASE 32-bit and I am trying to use Haskell on it.

I have installed package ghc-7.10.2 with pkg and then installed package hs-cabal-install-1.22.6.0 from /usr/ports/devel/hs-cabal-install.

Now, when I run cabal update I get:

$ cabal update
Downloading the latest package list from hackage.haskell.org
Segmentation fault (core dumped)

Running it as root causes the same problem.

I have been searching on different search engines but found no article describing this specific problem. Can you give me some hint on how to solve this problem or where I can find some documentation about it?

  • There is a bug report at bugs.freebsd.org/bugzilla/show_bug.cgi?id=204290, which states that is has something to do with LLVm support. Did you change any of the make config values? You might consider to add the configuration options to your question. – Raphael Ahrens Jan 27 '16 at 15:52
  • 1
    @RaphaelAhrens: Thanks for the hint. The problem was probably related to this bug. I had indeed chosen LLVM support. I have rebuilt everything and now it works. – Giorgio Jan 27 '16 at 17:48
1

There is a bug report which describes the same issue. There seems to be a problem when the port is compiled with LLVM support, which causes segmentation faults.

You need to run

cd /usr/ports/devel/hs-cabal-install
make config

to unset the LLVM support and to so avert the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.