1

I have an internal hdd from a windows computer. The computer suddenly started giving the message "No bootable device" during startup. So I would like to recover some of the data from the drive. To do this I figured I would connect it to my linux computer using a usb to sata adapter. but the hard drive is not being recognized. dmesg is not even reporting anything when I connect the usb. There is no physical damage to the drive as far as I can tell. It turns on properly, and I can feel the vibration of the drives spinning. I also know that the adapter is not faulty, I tested it with another drive. So is there anything else I can try, or is this drive a lost cause?

4
  • what happened with the other drive? how old is the disk? the host of the failed disk, is it a notebook? Have you tried another USB port? often USB ports are not all created equal in the same machine. How about dmesg in the original machine? – Rui F Ribeiro Jan 23 '16 at 4:49
  • @RuiFRibeiro The original machine is (1) windows (2) not able to boot (i.e. "No bootable device" is found by the machine) so I can't use dmesg on it. I suppose I could use a linux bootable flash drive on the original machine. Though I don't see it making much of a difference. I am confident that the usb cable is not a problem. The cable is a raw interface, it doesn't have any driver associated with it, so I don't have any reason to to believe it would work for one drive and not the other. Thanks for the tip. – JDOdle Jan 23 '16 at 5:57
  • If the disk isn't recognized by either controller then it's toast, though you should at least see something in dmesg when you plug in the usb adapter. – psusi Jan 26 '16 at 1:01
  • not if the internal disk controller is dead as I posted, psusi. The internal disk electronics seems kaput. – Rui F Ribeiro Jan 26 '16 at 7:13
0

I would be inclined to say the USB adapter seems to be needing an external source of energy (e.g. USB power alone is not enough to keep using the disk)

However, the fact that you are hinting the adapter works with another disk and both devices do not seem to see the disk points more to a dead disk internal controller.

I have had colleagues in the past that changed controllers from disks of exactly the same model with success. If the data is important, it can be worthwhile trying to buy second hand an old or mechanically damaged disk of exactly the same make and part number.

4
  • You are right in thinking that the usb power alone was not enough, however the usb cord has a third port to connect to a second power source, which is how I had it set up; so I know that is not an issue. I think you may have it right about the disk controller though. But not something I have the expertise to do. Thanks for your answer. – JDOdle Jan 23 '16 at 5:48
  • He's already tried two different disk controllers ( the native one, and the USB one ), so that rules that out. – psusi Jan 26 '16 at 0:59
  • The disk controller that is INSIDE the disk enclosure (from western digital, Seagate or whatever). If you open a disk, you will see a tiny board there. "...that changed controllers from disks of exactly the same model...". There is indeed a controller on the PC side that talks to a controller inside the disk. This weekend I got a storage medium from my wife that has exactly the opposite problem...it is recognised and the driver is loaded because the controller is fine, however the medium is damaged. – Rui F Ribeiro Jan 26 '16 at 7:11
  • So it was actually because the OP gave the very useful information that two different adapters are not able to see the information of the disk that I ruled out it is the internal controller of the disk. Edited slightly the post for it to become more evident. – Rui F Ribeiro Jan 26 '16 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.