4

I recently bought a notebook, it's an Acer Aspire VN7-571G and it has an integrated SD Card reader.

I've never used it since I bought it but I noticed today that by inserting an SD Card into the reader I got a lot of errors in dmesg (and obviously it doesn't work and I cannot get the contents of the card)

lsusb output

~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f2:b526 Chicony Electronics Co., Ltd 
Bus 001 Device 003: ID 04ca:3016 Lite-On Technology Corp. 
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg

[15574.049888] mmc0: error -5 whilst initialising SD card
[15574.885575] mmc0: error -5 whilst initialising SD card
[15576.721786] mmc0: error -5 whilst initialising SD card
[15577.557882] mmc0: error -5 whilst initialising SD card
[15578.392879] mmc0: error -5 whilst initialising SD card
[15580.230223] mmc0: error -5 whilst initialising SD card
[15581.064610] mmc0: error -5 whilst initialising SD card
[15581.900787] mmc0: error -5 whilst initialising SD card
[15583.724426] mmc0: error -5 whilst initialising SD card
[15584.560521] mmc0: error -5 whilst initialising SD card
[15585.403090] mmc0: error -5 whilst initialising SD card
[15587.240348] mmc0: error -5 whilst initialising SD card
[15588.075997] mmc0: error -5 whilst initialising SD card
[15588.913567] mmc0: error -5 whilst initialising SD card

lsmod

~$ lsmod | grep sd
sdhci_pci              24576  0
sdhci                  45056  1 sdhci_pci
rtsx_usb_sdmmc         28672  0
rtsx_usb               24576  2 rtsx_usb_sdmmc,rtsx_usb_ms

I've looked around on the internet but haven't found any useful information, plus I do have a dual boot with Windows 10 and I only can see when an SD card is inserted, but not its contents (even thought I already have the Realtek drivers installed) The same SD Card on another Windows computer does work without any problem at all.

I'm thinking here of an hardware fault, even if I never did anything with the SD Reader

1
  • Hi Andrew, please, add it as an answer so I can mark this problem as solved. My SD Card reader is now working properly on Linux. Thank you!! Jan 28, 2016 at 13:56

1 Answer 1

3

Andrew removed his SE account / his answer.
I solved by using this following GitHub repo and following the instructions: https://github.com/asymingt/rts5139

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .