2

I am trying to install a Linux distro without any success. The hard drive's current OS is Linux Mint although I usually boot into Windows 10. I have also tried installing Ubuntu and Arch Linux with the same problem: I do not get a fancy user interface and whenever I click Install my screen goes black and sometimes the PC reboots. I suppose it has to do with my external graphics card which is an Nvidia GTX 970 OC. My questions are:

  1. Is that a common problem with a fix to it that I haven't found?
  2. Is the support for newer hardware that bad on Linux? and of course
  3. Does anyone know to fix it?
  • 1
    UEFI or BIOS mode? – GAD3R Jul 30 '16 at 12:20
1

Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

  1. Immediately after the BIOS/UEFI splash screen during boot, with BIOS, quickly press and hold the Shift key, which will bring up a boot menu screen. With UEFI press (perhaps several times) the Esc key to get to the boot menu screen. Sometimes the manufacturer's splash screen is a part of the Windows bootloader, so when you power up the machine it goes straight to the boot menu screen, and then pressing Shift or Esc is unnecessary.

    enter image description here

  2. Press the e key to edit a menu entry. This will bring up an openSUSE Leap screen that looks like this:

    enter image description here

  3. Use the arrow keys to navigate when screen editing the above screen. Navigate to the line on this screen that starts with linuxefi.

  4. Replace splash=silent by nomodeset splash=silent. This change is only temporary — it will just be used once and GRUB won’t remember it in the future. Press Ctrl+X or F10 to boot with the nomodeset option that was added. If you make a mistake, press Esc to go back to the previous screen.

To make the change permanent you need to add it to the /etc/default/grub file. Append nomodeset inside the quotes of the line GRUB_CMDLINE_LINUX_DEFAULT="...". Then update your grub settings with sudo update-grub.

0

Your issue stems from running with -nomodeset option off. When arriving at the welcome screen enter f1 to get to the advanced welcome screen. After enter f6 to select -nomodeset.

For more details and discussion see this

  • thanks for the answer. unfortunately I don't get the interface you think i get. I am greeted with few options to choose by arrow buttons. The only other buttons that react are E (for some strange properties) and C for a grub console. – Niklas Vest Jan 21 '16 at 19:48
0

I also had what sounds like the same issue. I expect you have resolved it by now.

I pressed Fn'5 to change the kernel settings and chose 'No ACPI' which did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.