2

I have just installed (fresh-installation) over VMware Workstation 10 an Ubuntu 15.10 64-bit virtual machine.

Here, network interfaces names have been changed from 'ethX' to 'enXXXX'.

My target is been able to change the new names for the older ones, but after reading and trying different actions, none of them works. So, I'm going to explain the best I can what I have and what I have done in order to get your help.

Configuration:

  • System: Ubuntu 15.10 64-bit over VMware Workstation 10
  • Ethernet Card: NAT
  • Ethernet default configuration [dhcp] (graphic interface):
    • name: eno12345678
    • MAC: XX:XX:XX:XX:XX:XX
    • ip: 192.168.170.3
    • mask: 255.255.255.0
  • /etc/network/interfaces:
    • auto lo
    • iface lo inet loopback

Test:

  1. Modify "/etc/network/interfaces" file with:
    • auto eth0
    • iface eth0 inet static
    • address 192.168.170.3
    • netmask 255.255.255.0
    • gateway 192.168.170.2
    • dns-nameserver 192.168.170.2
  2. Create a rules file:
    • /etc/udev/rules.d/70-persistent-net.rules 'SUBSYSTEM=="net",ACTION=="add",ATTR{address}=="XX:XX:XX:XX:XX:XX",KERNEL=="enoXXXX",NAME="ethX"'
  3. Modify "/etc/default/grub" file:
    • 'GRUB_CMDLINE_LINUX', append "net.ifnames=0 biosdevname=0"
    • There is no 'grub2' folder at my machine, only 'grub'.
    • "grub-mkconfig -o /boot/grub/grub.cfg"
  4. There is no '/etc/sysconfig/' folder.
  5. Neither, there is no '/etc/sysconfig/network-scripts/ifcfg-*' files.

I would appreciate any help/tip you can provide for changing the name of the network interfaces. Is there any way to change this? Or would you recommend me another option?

One of the targets I have is to provide internet over USB to a portable device.

KR!

1

The easiest way to regain the old interface names is the modification of the grub file that you did (although I am unfamiliar with the biosdevname parameter. I would place these in the line starting GRUB_CMDLINE_LINUX_DEFAULT. After you have modified /etc/default/grub, you must execute sudo update-grub and reboot so that the new parameters will take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.