A while ago I encountered this issue with my favourite Viewer geeqie. My RAW files are displayed too small and I assume it's just the thumbnail which is shown, not the actual image. (It used to work smooth before)

There has been a bug filed: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800350 But I can't make sense of what I should do to have this issue solved.

Thank you

  • It would seem that the fixed version is available, but only in Debian unstable: "Version: 1:1.2.2-2 Distribution: unstable". Please see this, it should provide you a good start: unix.stackexchange.com/q/8049/44760
    – zagrimsan
    Jan 21, 2016 at 8:35
  • I'm using ubuntu - a little weird, I have geeqie Version 1:1.2-3build1.
    – Qohelet
    Jan 21, 2016 at 9:39
  • You didn't state which distribution you're running but linked to Debian bug tracker so I could only guess that is what you're using. I don't think there's much use comparing version numbers between different repositiories, especially on the level of minor version and fix numbers...
    – zagrimsan
    Jan 21, 2016 at 12:10

1 Answer 1


Essentially, you have three choices (and this is a generic answer).

  1. Wait for the patch to arrive in your existing Linux distribution. For Debian this would be at the next Stable release most likely. For Ubuntu, the patch may make its way in to the existing current release, or you may need to wait for the next major release (I'm not familiar with Ubuntu's release schedule). The patch is in 'xenial' already, if that helps.

  2. Remove the packaged version in from your machine, download the patched source for the package in question, compile it and use a locally built version. This is the general approach for running newer versions of software than your distribution supports. However, it assumes the upstream party has implemented the fix (which is the normal approach, but it's not always true), as well as assuming you know how to install the relevant build tools and compile / manage local apps. You may need to start downloading shared library source files as well, if the required set are newer than your distribution supplies.

  3. Find someone else who has backported / compiled the package for your distribution and use that. This is often easier than option 2, but may require you to install additional dependencies (such as shared libraries) and might have implications for your environment. There are sometimes official backports (such as Debian Backports) and sometimes unofficial sources.

There are other subtle options (for example, you could download the source package for your existing distribution, download the patches, and apply the patches to the source, before rebuilding the package, this may resolve dependency issues, but does require you to understand build environments and patch management), but given you don't provide much background in the question, I stuck with the three most basic approaches.

For Geeqie specifically, I would wait and see when the fix makes it into your existing Ubuntu distribution, because I think Ubuntu roll fixes like this out in a continuous manner (unlike Debian).

  • 1
    Solved it, thank you. I downloaded the sources from xenial and compiled them. Everything works =)
    – Qohelet
    Jan 21, 2016 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .