I've just switched from Xorg to Wayland, which means I've also switched to libinput. I'm also using GNOME 3 and GDM.

Since switching, scrolling has become very jumpy. As I drag two fingers vertically across the touchpad as slowly as possible and pausing periodically as I go, after a certain distance it will "jump".

This doesn't happen in all applications; I'm guessing anything running in Xwayland doesn't have the issue. Such applications still scroll and accelerate faster than I'd like, but I assume that's a separate issue.

The problem occurs in both GTK+ and Qt applications.

For example, when scrolling in gedit, which supports smooth scrolling:

  1. Start on line 1
  2. Scroll smoothly until line 5
  3. As soon as I hit line 5, no matter how slowly I'm scrolling, it jumps to line 10.
  4. Scroll back up toward line 1, going smoothly until line 5
  5. At line 5, jumps to line 1

The jump always happens 5 lines from where I start scrolling. If I stop scrolling but leave both of my fingers on the touchpad, it doesn't actually count as stopping.

I have a Synaptics touchpad on a Yoga 900:

Device:           SYNA2B29:00 06CB:77C6
Kernel:           /dev/input/event14
Group:            5
Seat:             seat0, default
Size:             91.53x59.95mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none

I'm running Linux 4.4 with some driver patches I stole from 4.5 to get the hardware on the Yoga 900 working properly. Up-to-date Arch Linux with testing repository enabled (core is still on 4.3, but 4.4 has patches that I need).

linux-custom 4.4-4
libinput 1.1.4-1
wayland 1.9.0-1
gnome-shell 3.18.3-2
xorg-server-xwayland 1.18.0-4

I'm at a bit of a loss for how to troubleshoot this because so many factors are involved, and I'm unfamiliar with libinput and Wayland. I switched to Wayland because X was having trouble with my high-PPI display in many cases. Wayland also seems to better utilize my CPU's integrated graphics. So for now, I'd like to stick with Wayland, even if I can't find an immediate solution. I'd prefer to solve this on my own (via patches, hacks, whatever) rather than wait for a proper fix to be developed, tested, and released.

  • Could someone add a libinput tag? I can't because I lack the reputation, and it doesn't exist yet.
    – Zenexer
    Jan 21, 2016 at 4:17
  • 1
    Added the tag, What is the actual question? Who to contact within the development group of libinput? What is a better alternative for Wayland that doesn't have this issue? Better to be explicit than to let people guess (wrong).
    – Anthon
    Jan 21, 2016 at 5:20
  • @Anthon Thanks. I added a question (kind of). I'm open to any suggestions, but I have a lot of trouble getting messages sent to mailing lists. They seem to break DMARC, so I have to use a throwaway email that doesn't have all the fancy stuff.
    – Zenexer
    Jan 22, 2016 at 8:25
  • I don't think the issue is libinput. Scrolling works fine in Weston. I can't get Weston to scale for my HiDPI display, though, for some reason. Otherwise I'd be content with that.
    – Zenexer
    Jan 22, 2016 at 9:11
  • 2
    I get (likely) the same issue on Fedora 23. It seems that xwayland/libinput/gnome/whatever is sending both smooth-scroll events and also the old-style button-based scroll events (which scroll a few lines) and all the applications I've found look at both so the jerkiness appears. This is all the evidence I've found of anyone with the same problem. FWIW, gnome on X works fine. Feb 4, 2016 at 23:58

1 Answer 1


Good news!

This has been fixed in the latest release, Gnome 3.20. With this along with lots of other bugs, Wayland is (IMHO) finally becoming everyday-usable.

I did find the commit where the issue was fixed, but I'm having trouble finding it again. In any case, @DanRobertson's guess on the cause is correct and has been fixed.

  • I have Gnome 3.28 and still have the issue on Chrome (73.0.3683.103) with Ubuntu (18.04)
    – Jav
    Apr 26, 2019 at 10:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .