1

I am on RHEL 6.7 and have a korn shell script that does check pre-reqs, prepares the system for rpm install's (creating directories if they are not already that are required by the product), stops services, install rpm's and starts services back up. All is working well until the rpm installation. 6 out of 10 rpm's isntall and then the rpm install hangs.

Talking to product owner , they advised that they would prefer us to run the rpm installs in bash shell. So I did a small bash shell script, that installs, only rpm's and it did went well.

now rather than changing my entire master script to bash, I am calling the bash script that installs rpm's within my ksh script and it still hangs during rpm installation.

Any thoughts what might be causing this.

Here is the code when running rpm install within ksh

rpm --prefix $MOUNTINST -ivh $BIN/MQSeriesRuntime_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesSDK_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesServer_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesClient_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesSamples_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesJava_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesJRE_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesMan_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesExplorer_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesAMS_6-8.0.0-0.x86_64.rpm \
$BIN/MQSeriesGSKit_6-8.0.0-0.x86_64.rpm 2>&1 | tee /tmp/MQinstV80.out

if_error $? "Installing MQSeries V8.0"

chown mqm:mqm /tmp/MQinstV80.out
if_error $? "Changing ownership of MQinst.out"

 Temporary workaround till IBM gets back with a fix
mkdir $MOUNTINST/logs
chown mqm:mqm $MOUNTINST/logs
chmod 755 $MOUNTINST/logs

And here is the code sample after making changes to run the bash script within ksh script, that was successful when running standalone

#rpm --prefix $MOUNTINST -ivh $BIN/MQSeriesRuntime_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesSDK_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesServer_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesClient_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesSamples_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesJava_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesJRE_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesMan_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesExplorer_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesAMS_6-8.0.0-0.x86_64.rpm \
#$BIN/MQSeriesGSKit_6-8.0.0-0.x86_64.rpm 2>&1 | tee /tmp/MQinstV80.out

/var/mqm/trace/WMQUNX8000.00/LINUX/MQV8000GA/6/x86_64/install.sh


#if_error $? "Installing MQSeries V8.0"

#chown mqm:mqm /tmp/MQinstV80.out
#if_error $? "Changing ownership of MQinst.out"

# Temporary workaround till IBM gets back with a fix
#mkdir $MOUNTINST/logs
#chown mqm:mqm $MOUNTINST/logs
#chmod 755 $MOUNTINST/logs
  • 1
    Do your scripts have shebangs? It's very unclear to me which is the bash code and which is ksh. And what is the contents of /var/mqm/trace/WMQUNX8000.00/LINUX/MQV8000GA/6/x86_64/install.sh? – Wildcard Jan 21 '16 at 3:48
  • Yes I do have shebangs. The code I put in here is part oh ksh. Install.sh is the bash. Install.sh has the exact same tom install commands as in the above code snippet. – MO12 Jan 21 '16 at 3:58
  • 2
    you should probably quote stuff. – mikeserv Jan 21 '16 at 4:55
  • Related: unix.stackexchange.com/q/131766/135943 @mikeserv :D Yep. – Wildcard Jan 21 '16 at 5:41
  • What shows up in /tmp/MQinstV80.out ? Is there enough space for logging ( in /tmp ) and for Installation ? When it is hanging , try strace to check where it is hanging. Try running the 11 RPM Installs with 11 separate commands and see which RPM is stuck, and update the script to Install that RPM with -vv options. Finally, is your ksh script doing something strange to the environment or PATH ? – Prem Jan 21 '16 at 7:50
0

I will assume a lot, your descriptions lack much needed information, and mislead otherwise.
I would assume that install.sh is the script you expect to run in bash, presented by you as:

a="/var/mqm/trace/WMQUNX8000.00/LINUX/MQV8000GA/6/x86_64/install.sh"

If that is true, call it as:

/path/to/bash "$a"

Of course, install.sh should have this code Again, (sigh)

  • assuming if_error could be implemented by the function if_error in code below.
  • $bin is the value of a bin folder like /usr/bin
  • You do not have this problem.
#!/bin/bash
# If bash is not installed in /bin/bash,
# use the correct path above.

bin="/usr/bin"
mountinst='some wild guess of its value'

if_error(){
    if [[ $1 != 0 ]]; then
        shift
        echo "$@"
    fi
}

rpm --prefix $mountinst -ivh $BIN/MQSeriesRuntime_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesSDK_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesServer_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesClient_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesSamples_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesJava_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesJRE_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesMan_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesExplorer_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesAMS_6-8.0.0-0.x86_64.rpm \
$bin/MQSeriesGSKit_6-8.0.0-0.x86_64.rpm 2>&1 | tee /tmp/MQinstV80.out

if_error "$?" "Installing MQSeries V8.0"

chown "mqm:mqm" "/tmp/MQinstV80.out"
if_error "$?" "Changing ownership of MQinst.out"

# Temporary workaround till IBM gets back with a fix
mkdir "$mountinst/logs"
chown "mqm:mqm" "$mountinst/logs"
chmod "755" "$mountinst/logs"
  • Thanks for the tip on using path as variable ans running it under bash. I haven't tried it. but yes I did have shebangs for bash in install.sh. sorry for leaving out many details to keep you guessing, but you did guess it right. – MO12 Jan 22 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.