0

so I'm trying to mount my external hard drive automatically on my server running Ubuntu 14.04.

I've tried editing fstab directly, I've tried gnome disks and I've tried Usbmount. None of them work after my server automatically resets every morning.

My fstab file looks like this

  GNU nano 2.4.2                                                             File: /etc/fstab                                                                                                                          

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=e08eb43c-11ba-40e1-bc9d-122c364960d7 /               ext4        errors=remount-ro 0       1
/swapfile   none    swap    sw    0   0
#/dev/sdb2    /mnt/ext/drive01               ntfs-3g    errors=remount-ro 0           1
UUID=764A847D4A843C3D /mnt/ext/drive01 ntfs-3g nosuid,nodev,nofail,x-gvfs-show 0 0

The bottom most entry is the one relevant to the hard drive. It just simply wont auto mount on start up. I have to go into it, unmount it and then remount it other wise I get the error Failed to mount "Backup Drive". Error when getting information for file /mnt/ext/drive01: Transport endpoint is not connected"

If anyone could help clear up the problem that'd be great.

  • Anything in the system log? – Hauke Laging Jan 21 '16 at 0:20
0

To verify that you have your /etc/fstab set up correctly, the mount point exists, you're not relying on a disk manager to mount the drive for you, and you have ntfs-3g installed, can you try rebooting the server, then mount it with this command?

sudo mount /mnt/ext/drive01

  • When I try that it says "Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the fuser command" – ÁppleAssassin Jan 21 '16 at 0:44
  • Upon using umount /dev/sdb2 and then using mount /mnt/ext/drive01 it works. But I still have to unmount it for it to properly mount. – ÁppleAssassin Jan 21 '16 at 0:47
  • 1
    OK, that confirms my suspicions. The disk is being automatically mounted by an application and it won't let you mount it twice. Maybe try unmounting it again, log out, log back in, and run: sudo fuser /dev/disk/by-uuid/764A847D4A843C3D – vik Jan 21 '16 at 1:40
  • If it is udisks, then this might help: askubuntu.com/questions/124094/…. – vik Jan 21 '16 at 2:34
  • 1
    For anyone wondering why it wasn't working. I forgot to bloody uninstall Usbmount which was mounting it before fstab was for some reason. – ÁppleAssassin Jan 22 '16 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.