1

My environment is VirtualBox 5.0.8 / Centos 7(64) and I create a local repository "local_centos7" from "CentOS-7.0-1406-x86_64-DVD.iso"

yum groupinstall "GNOME Desktop"

some errors occur

Error: Package: systemd-python-208-11.el7.x86_64 (local_centos7)
           Requires: systemd = 208-11.el7
           Installed: systemd-219-19.el7.x86_64 (@base)
               systemd = 219-19.el7
           Available: systemd-208-11.el7.x86_64 (local_centos7)
               systemd = 208-11.el7
Error: Package: libproxy-mozjs-0.4.11-6.el7.x86_64 (local_centos7)
           Requires: libproxy = 0.4.11-6.el7
           Installed: libproxy-0.4.11-8.el7.x86_64 (@base)
               libproxy = 0.4.11-8.el7
           Available: libproxy-0.4.11-6.el7.x86_64 (local_centos7)
               libproxy = 0.4.11-6.el7
Error: Package: cryptsetup-python-1.6.3-2.el7.x86_64 (local_centos7)
           Requires: cryptsetup-libs = 1.6.3-2.el7
           Installed: cryptsetup-libs-1.6.7-1.el7.x86_64 (@base)
               cryptsetup-libs = 1.6.7-1.el7
           Available: cryptsetup-libs-1.6.3-2.el7.x86_64 (local_centos7)
               cryptsetup-libs = 1.6.3-2.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My platform is X86_64 and I have installed Installed: libproxy-0.4.11-8.el7.x86_64 (@base) ,why centos7 requires libproxy = 0.4.11-6.el7 ?

Gnome Destop need X86_32 packages ? Can anybody tell me why and thank you very much

3
  • May be you have updated your version to CentOS Linux release 7.2... and now you are trying to use older packages from this media. Check with: lsb_release -a.
    – taliezin
    Jan 20, 2016 at 14:47
  • @taliezin Linux centos7 3.10.0-327.3.1.el7.x86_64
    – LawrenceLi
    Jan 20, 2016 at 17:43
  • I think your CentOS is updated, can you try installing gnome through network, not from local repository?
    – taliezin
    Jan 20, 2016 at 17:48

0

You must log in to answer this question.

Browse other questions tagged .