1

I am working with isc-dhcp-server on ubuntu 14.04.1, and i don't want that it run on start up so I disabled it from rc with

sudo update-rc.d -f isc-dhcp-server remove

But it still run on startup, I look at rc.local, .bashrc and didn't see any call to it. I tried to check with sudo sysv-rc-conf But all run devel for isc-dhcp-sever are disable, What else could I check, to disabled it form start up. thz

  • Can you rename conf files for the service to something like: mv isc-dhcpserver.conf isc-dhcp-server.atop and mv isc-dhcpserver6.conf isc-dhcp-server6.stop and see if it works? – taliezin Jan 20 '16 at 18:03
  • Hello, i did it moving dhcp.conf with: 'sudo mv /etc/dhcp/dhcpd.conf /etc/dhcp/dhcpd.conf.stop', but how i move it when i start isc, it doesn't work, so should i create a script or something?, thz – lobo115 Jan 20 '16 at 18:19
  • Oh, if you want to start it it is trying to find *.conf files. – taliezin Jan 20 '16 at 18:20
  • Hello, my bad, i mean that i want start isc, but because i move it it doesn't start now, should i create a script that move it again to isc-dhcpserver.conf, and then start it, but then i need use another script to disable it, i think. – lobo115 Jan 20 '16 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.