1

I installed Puppet Agent on a CentOS 7 server. I installed Puppet Master on a different CentOS 7 server. I'm using the free version of Puppet on both servers. The Puppet Agent server requested a certificate. I signed it on the Puppet Master server. There is no software firewall on either server. There is no firewall between the servers. I temporarily enabled port 8140 with SSHD. I used SSH to verify port 8140 was open. I then reverted SSHD to only listen on port 22. Port 8140 wasn't blocked. nslookup on the IP addresses and ping against the domain names shows that both servers have correct networking information about the other server. These are new servers. Puppet has never worked on them before. I created a simple manifest. I applied it to the Puppet Master server locally. It worked without errors. I then tried to apply it to the Puppet Agent server. It didn't work.

From the Puppet Master server, I ran this:

puppet agent neat.pp --server hostNameOfPuppetAgentServer --verbose

There were no errors on the Puppet Master server after I pressed enter. There was no output at all. This produced no logs on the Puppet Agent server. There was no evidence it worked on the Puppet Agent server. I checked, and the effects were not performed.

On the Puppet Master server I ran this:

puppet agent --server hostNameOfPuppetAgentServer --test

The results included "Connection refused -- connect (2)." What is wrong? I expect the manifest to work on a Puppet Agent node.

  • Puppet Master server does not push rules to the slaves, but its the slave that pulls the rules from the master. You go have to start the Puppet Agent daemon on the puppet slaves, not on the master. – Sree Jan 20 '16 at 5:14
  • run ` puppet agent --server <puppet-master> --test` on your puppet agent. Not on your puppet master. – Siddharth sharma Jan 20 '16 at 6:37
0

On your puppet client, edit puppet.conf [main] section include server = <puppet_server_name>.

And try run puppet agent -t .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.