I think I really messed up this time. So I have a laptop that dual boots Windows 7 and Linux Mint 11. I was trying to boot into Windows 7 but it would just have a black screen with a blinking cursor. So I turned off my computer and tried again.

Still a black screen with a cursor. So I thought "well it must be broken somehow and I remembered seeing something like 'Windows Recovery' from the boot menu so I should try it." So when I turned on my computer a third time I selected 'Windows Recovery' (Something like that I can't remember exactly what it was called). After I had selected that I got a white Windows window that said in big red letters "ERROR". I turned off my computer again a turned it back on expecting the Grub menu to reappear. I was wrong. Instead I am greeted with error: no such partition grub rescue>.

Then I put in a live CD for ubuntu 11.04 and tried looking at my partitions using the disk manager. Looking at my partitions I notice that there isn't a Linux partition anymore and in its place is a unallocated space partition yet the Linux Swap partition is still there. My windows partition is still fine and I can access the files in it. If you understand what has happened, is there anyway I can get my files back? I don't care about reinstalling the OS again. I just want those files that are in the Linux Mint partition.

  • 1
    Other than you trying to use an Ubuntu Live CD to rescue this, this is offtopic for Ask Ubuntu. I sympathise with your situation, but maybe you should head over to the Linux Mint forums? – Caesium Nov 26 '11 at 16:37
  • @Caesium You can just flag Mint questions to be moved to unix/linux stackexchange – Jorge Castro Nov 26 '11 at 21:45

I think when you you went with the option WINDOWS RECOVERY, Windows must have changed the boot loader (grub) to theh Windows boot loader, which will not detect any OS but Windows.

If that is the case just boot your system with a Ubuntu live cd and install boot repair, that is enough. After that the system will restart itself and you will see all the OSs installed in your pc if already you have installed it then open it and click on Recommended repair button, that is enough to get Windows and Ubuntu


If the unallocated partition has still the same starting and ending cylinder, you can just use linux fdisk to make it a linux partition again. After that it should be no problem to mount that partition.

The answer from VENKI looks like Ubuntu can do this for you in a more convenient way, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy