0

I have a new clean installation of CentOS 6.7, it is not on a VM, but on a dedicated notebook. During the installation procedure I've configured my WiFi connection and have added it on eth0 pre-configured connection.

I have specified all:

  • name of the connection
  • SSID
  • mode: hoc
  • band: automatic
  • channel: pre-configured
  • MTU: automatic
  • checked automatic connection box and available for all users box too

In security section I have inserted WPA & WPA2 Personal, then the corresponding password of the router.

In IPv4 section: automatic (DHCP) method and checked the completion of this connection with IPv4 addressing.

In IPv6 section: ignore method

I log in with root user and corresponding password for have all privileges.

The WiFi spy on the WiFi key of the notebook is on, the router is on and Internet works with other devices.

But if I ping google.com, it says:

unknown host google.com

while if I ping 8.8.8.8, it says:

Network is unreachable

Since I have configured all the connection data and checked the automatic connection box, I expected that the connection would be automatic when I log in.

Is there something that I did wrong? Hope in some friendly advice.

  • What is the output of ifconfig, have you disabled iptables – Mongrel Jan 18 '16 at 13:28
  • Are you accessing the computer via a GUI or a terminal? – Paul Calabro Jan 18 '16 at 13:30
  • Oh yes, I forgot: this is a minimal installation, I access it by terminal and haven't a GUI. – joe Jan 18 '16 at 13:37
  • Here's ifconfig output: Link encap: Local Loopback inet addr: 127.0.0.1 Mask: 255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:20 errors:0 dropped:0 overruns:0 frame:0 TX packets:20 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1376 (1.3 KiB) TX bytes:1376 (1.3 KiB) I haven't do anything after clean installation, how can I disable iptables? Thanks. – joe Jan 18 '16 at 13:42
0

/etc/init.d/iptables stop will disable the iptables
chkconfig iptables off

  • no wait please! I'm an idiot: since the notebook is new,I didn't know this, but the spy on wifi key is orange, so it means that it not finds the wifi device. The spy must be blue when wifi is connected, while I though that in that case it would turn off the light. Anyway your instruction works, but this definitely isn't the problem, there is something that I need to do for grab the wifi signal. Please help, in the meanwhile I'll search a solution too!! – joe Jan 18 '16 at 14:43
  • If you have a GUI, you must be having NetworkManager on your top right hand side of the corner. you can assign IP from there. If isn't showing you the anything that means your drivers is not detected. – Mongrel Jan 18 '16 at 14:46
  • unfortunately I'm using a minimal installation without GUI... maybe I'll install a new version with GUI to make things easy. Thanks anyway!! – joe Jan 18 '16 at 15:01
  • Regardless of the actual issue, this answer needs more explanation about why you need to run those commands what they're fixing, otherwise it's not as helpful as it could be. – EightBitTony Jan 18 '16 at 15:17
  • default iptables are not having out going rules, it just has SSH enabled – Mongrel Jan 19 '16 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.