1

I have a JetWay PC (JBC375F3AW) running CentOS7. When it boots up everything works OK. If I remove the cable going to the DVI port and re-connect it, it wont work. The same goes if I boot the box with out the cable connected. If after boot I connect the cable there is nothing. I ruled out the monitor as I tried several different monitors all with the same result. The box just has the basics of CentOS (no x windows etc.). I tried installing the Intel Linux graphics installer but it wants some form of x windows. When I do: lshw -class video I get:

[root@chattin-purple ~]# lshw -class video
*-display               
   description: VGA compatible controller
   product: Atom Processor Z36xxx/Z37xxx Series Graphics & Display
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 0e
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:91 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:f080(size=8)

One more note. When I ssh in to the box and tell it to reboot the led on my monitor switches from orange (which means no signal) to green for a split moment as the box goes down. It also shows a linking cursor. This seems to indicate to me that it's more of a Linux setting then the hardware on the box.

migrated from serverfault.com Jan 18 '16 at 10:42

This question came from our site for system and network administrators.

  • Have you actually tried to connect and disconnect the cable while in the BIOS setup menus to rule out a Linux problem? – Rui F Ribeiro Jan 18 '16 at 10:43
  • 1
    Yes. In fact if when grub loads and it asks me for a kernel to use if I disconnect and reconnect then there is no issue. It's only once the box boots up. – Dovid Bender Jan 18 '16 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.