2

I've got a weird problem. I installed bumblebee and when I start Xorg with startx it freezes the system completely (cannot switch tty or REISUB). But, when I use bbswitch to turn my dedicated graphics card ON startx does work and, seeing the differences in fps when running glxspheres64 and optirun glxspheres64, it looks like bumblebee does work correctly.

I thought this should work even when bbswitch is OFF because bumblebee will start the dedicated graphics when necessary?

My system:

  • Model: Asus N551VW
  • OS: Arch
  • CPU: Intel i7 6700HQ
  • Dedicated: Nvidia 960m

1 Answer 1

1

I solved the problem, it appears to be related to both bumblebee and the Nvidia driver. See also this Bumblebee issue.

When Bumblebee wants to turn off the Nvidia card, it will try to run rmmod nvidia. But when I run this command Arch says it cannot unload this module because it is used by nvidia_modeset. Apparently, this new module was added recently to the Nvidia driver and causes Bumblebee to lock up the system when starting startx (because he cannot turn off the Nvidia card).

So currently, there is no solution, but when Bumblebee 4.0 releases there probably will be one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .