1

So, there were already questions about ignoring ata devices (like How to tell Linux Kernel > 3.0 to completely ignore a failing disk?) from where I got the info that one has to add something like libata.force=2:disable to your kernel argument line. However, for some, reason, on one of my system's controller cards, there are 2 broken ports which are always probed, but I can't switch the card yet. In the first place, there was only one broken port and I could just use the above solution and it worked just fine. Then, when the other port died, I thought I could just add another one of these, like "... libata.force=2:disable libata.force=4:disable" which lead to the result that only port 4, and not port 2 was getting ignored, like if the second argument was kinda overriding the first one. Then I tried "... libata.force=2:disable,4:disable" which also didn't work for me.

Q: How can I make the kernel ignore multiple ata devices?

  • Just a hopefully helpful addition: I fogot to explain what it does wrong with the second try. It seems to always disable ata4 and always leave ata2 enabled when trying it like that. – Lollen Jumplan Jan 17 '16 at 16:19
  • Another addition with more infos: By looking at the kernel command line after reboot with journalctl, I can confirm that the system recognizes my changes, so it indeed passes to the kernel properly what I add in /etc/default/grub. I tried swapping the numbers, too, so it reads libata.force=4:disable,2:disable , but still, it does the same thing as before: leave ata2 on, turn ata4 off. – Lollen Jumplan Jan 17 '16 at 16:33
  • Does libata.force=2:disable,4:disable turn off ata2, but leave ata4 on? – Justin C May 14 '16 at 14:50
2

It's always good to refer to Kernel Paremeters doc: https://www.kernel.org/doc/Documentation/kernel-parameters.txt

There we can read, for libata.force:

[LIBATA] Force configurations. The format is comma separated list of "[ID:]VAL" where ID is PORT[.DEVICE]. PORT and DEVICE are decimal numbers matching port, link or device.

Your ports are 2 and 4, and your VAL is disable. Thus you're looking for libata.force=2:disable,4:disable.

  • Thank you, indeed I didn't have a look at these parameters (I didn't even know these docs existed) - but if you look above, that's intuitively what I wrote on the second try, and it strangely still doesn't seem to work... – Lollen Jumplan Jan 17 '16 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.