0

I'm running a Fedora 23 workstation using FirewallD by default,the machine has 2 NIC's one for internal and external traffic.

so id though I'd config the firewall to reflect this with the following commands

firewall-cmd --permanent --zone=internal --add-interface=enp5s0
firewall-cmd --permanent --zone=external --add-interface=enp3s0
firewall-cmd --permanent --zone=external --add-source=11.22.33.44/32
firewall-cmd --set-default-zone=internal
firewall-cmd --reload

how every all traffic is now being dropped even on IP I've trusted.. my next step was to disable firewalld from running entirely with systemctl stop/disable/mask just to make sure it doesn't start again on reboot.

but event with the firewall disabled external connection are still being dropped.

Any help on the matter would be much appreciated

thanks

3

These are the things I normally do on a system with FirewallD.

  1. Did I do a complete reload? firewall-cmd --complete-reload
  2. Are my interfaces in the right zones? firewall-cmd --list-all --zone=internal and firewall-cmd --list-all --zone=external
  3. With FirewallD "stopped", did I make sure it was really stopped? iptables -nvL and systemctl status firewalld.service
  4. Are rules still showing up? iptables -F

Those are the things I would do to make sure whatever you were configuring is showing up or working properly. Something tells me the interface information is more than likely incorrect. If you managed to get to point 4, and then it starts working, I would start completely from defaults that firewalld has.

Side note: If you disabled Network Manager and you are using --add-source, it will not work. You need to go back to regular iptables if so. But, Fedora does have Network Manager by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.