1

On Ubuntu 14.04, I am trying to bind all the interrupts to core 0 and 1 out of 4 cores. I have disabled the irqbalance daemon via file /etc/init/irqbalance.override. Then I went to every interrupt in /proc/irq and changed the files /proc/irq/<irq-num>/smp_affinity_list. But what I see that interrupts LOC(/etc/init/SERVICE.override), IWI(/etc/init/SERVICE.override) and RES(/etc/init/SERVICE.override) are still being processed on every core, all other interrupts are binded correctly to expected core. Why I am not able to bind these LOC, IWI and RES interrupts? or how to bind them permanently to particular core when irqbalance is disabled? Even I have modified file /proc/irq/default_smp_affinity to point to core 0 and 1. but no effect.

One more observation. I am not able to bind the cpu list for interrupt 0 and 2. While interrupt 0 seems to be occuring only on cpu 0 and interrupt 2 is not in the file /proc/interrupts and seems to be occurred only for 0 times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.