2

I want to run PyPy 4.0.1 on Amazon Linux (AWS EC2), and then downloaded and unzipped the tar.bz file. Also, I created the symbolic links to fix problems, such as

pypy: error while loading shared libraries: libbz2.so.1.0

Here are symbolic link I created:

sudo ln -s /lib64/libbz2.so.1.0.6 /lib64/libbz2.so.1.0
sudo ln -s /lib64/libcrypto.so.1.0.1k /lib64/libcrypto.so.1.0.0
sudo ln -s /usr/lib64/libssl.so.1.0.1k /usr/lib64/libssl.so.1.0.0

However, it seems that PyPy will check the version of those libraries. I got error messages:

pypy: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /path/to/pypy-4.0.1-linux64/bin/libpypy-c.so)
pypy: /usr/lib64/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /path/to/pypy-4.0.1-linux64/bin/libpypy-c.so)

Does anyone have a solution to resolve this problem? I would be grateful if you can provide any suggestions or useful information.

1

After searching for viable solutions, here are two solutions:

  1. Download and install PyPy 2.4 via yum.

    sudo yum --enablerepo=amzn-preview install pypy

  2. Download the Portable PyPy.

    https://bitbucket.org/squeaky/portable-pypy/downloads/pypy-4.0.1-linux_x86_64-portable.tar.bz2

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.