3

This is what is the Energy Efficient Ethernet.

The problem is, that in lot of environments it conflicts with other features and stuff so i really need to disable it.

I read that something can be achieved with:

ethtool --set-eee eth0 eee off

However this is the response i have to that command is:

Cannot get EEE settings: Operation not supported

It seems that my nic is not supported by ethtool. By lacks of documentation on internet and the real need of disabling this unuseful feature I wonder: how i can bypass ethtool and disable the feature on my nic ?

The nic should be this according lspci -m:

03:00.0 "Ethernet controller" "Realtek Semiconductor Co., Ltd." "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller" -r15 "Gigabyte Technology Co., Ltd" "Motherboard"

Basically I'm trying to find a linux way to do what i normally can do under windows in this panel (in the image is an intel nic, but you got the point):

nic settings panel

  • Does your Realtek NIC support EEE control under Windows? The equivalent to the dialog box you show does work on Intel NICs under Linux, so it would be interesting to know if your NIC supports the feature at all. And just out of curiosity, what kind of issues to you get with EEE? – Stephen Kitt Jan 17 '16 at 14:12
  • The issue i get is a bit complex, in short what happens: I use my eth0 but not directly, eth0 is normally unconfigured and i just use a pppoe connection over it, when i pull out the cable the device go in green state almost a sleep state. If i plug back the cable the pppoe connection never starts because the card stay sleeping. A solution to this i found is assign to eth0 an ip of the same subnet of the modem, first of later the modem knowing the mac address of the eth will try to contact her and she will wake up back again, once the channel is re-enstablished pppoe will go back working too. – user3450548 Jan 17 '16 at 15:20
  • In short i'm obliged to have the eth0 configured and on the same subnet of the modem, thing that i don't like too much because i don't need the eth0 at all except for allow pppoe have a link. – user3450548 Jan 17 '16 at 15:39
  • Does it work if you bring eth0 up without giving it an IP address? Try ifconfig eth0 up as root. – Stephen Kitt Jan 17 '16 at 16:13
  • We tried everything, even upgrading the kernel but seems that ethtool can't deal with this realtek card. And i have no other clues in how disable eee on it. – user3450548 Jan 18 '16 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.