3

After using Fedora 22 for some time (3-4 months) I encountered a problem.

THE PROBLEM

After choosing Fedora in grub there appears to be a loop (I do not know in what- systemd? gdm?):

[  OK  ] Created slice user-1000.slice.
         Starting User Manager for UID 1000...
[  OK  ] Started USer Manager for UID 1000.
         Stopping User Manager for UID 1000...
[  OK  ] Stopped User Manager for UID 1000.
[  OK  ] Created slice user-1000.slice.
[  OK  ] Created slice user-1000.slice.

ENVIRONMENT

one system: F22 recently updated, Lenovo Think Pad L430 (intel i5, Nvidia with Optimus) I had installed bumblebee with its latest version of NVidia drivers.

WHAT I'VE TRIED


booting another kernel verison did not worked ( I had 2 previous kernels )


booting in rescue mode and searching for clues (logs) but I don't know what to search for and where. Can you help? From what I've searched there is not much clues.


booting in rescue mode and trying to update but I could not get connection. When I try to do something with NetworkManger eg. stop/ start I get:

 Error getting authority: Error initializing autority: Could not connect: No such file or directory (g-io-error-quark, 1)

I've tried also to rollback via dnf history rollback but since I do not have a network connection, the package manager could not download uninstalled packages (I had turned off cache/backup packages by default)

SIMILAR PROBLEMS

ref 1

QUESTION

Can someone tell me how to fix this issue? Or to get connection so as I can try to rollback or something, please! Ask for logs and I'll post what is needed.

9
  • I'm not quite clear on the problem. Do you mean that the system boot stops at the above? Does the final line repeat more than twice?
    – mattdm
    Jan 18 '16 at 16:24
  • 1
    And, did this start right after installing the Nvidia drivers?
    – mattdm
    Jan 18 '16 at 16:24
  • yes, it's a loop (look up screen in "ref 1" in SIMILAR PROBLEMS section. The drivers was not touched, they were working just fine for some time. I do not know what caused this issue.
    – BPiek
    Jan 19 '16 at 17:17
  • I have clicked to update drivers (in NVidia's GUI), but it said that drivers are up to date and there is nothing to download (or sth like that). I dont remember if it was just before the last restart or earlier.
    – BPiek
    Jan 19 '16 at 17:23
  • 1
    I've tried to chroot and update also, reinstall systemd, uninstall bumblebee etc. Nothing worked. Ended up installing fresh F23 :( I feel defeated...
    – BPiek
    Jan 25 '16 at 19:38
1

I had the same symptom, after moving a F23 installation (ssd) to a different motherboard+chipset. The solution was to change the Secure Boot settings in BIOS. It was set to "Windows 7," and I set it to "Other OS." I guess the first motherboard had this setting by default.

I became aware that this may be the issue when I tried to reinstall the Nvidia driver (since I was able to get to terminal 2) and it asked me about kernel module signing, since it detected that Secure Boot was enabled.

0

Had the same in Fedora 24 boot (start - stop - remove user 1000 loop after boot)

My simple solution (worked on both my machines):

-Alt-F[3-6] to prompt at console.

-Just wait a minute or so to let the screen calm down

-login as root

-go to init 3 (non graphical login boot mode) with command 'telinit 3'

-in init 3 mode, give command 'reboot'

-reboot flawlessly comes up in init 5 at GDM login screen

I still don't know why this works - but it does ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.