0

I am installing Arch on my new laptop but for some reason when starting startx Arch freezes completely. Before this happened I already had a working KDE environment, but then I had to force a reboot (because my screen light fell out) and after this I could not start Xorg anymore without freezing my system. Even the magic keys (REISUB) don't work, I have to do a forced reboot every time. Also, my fans started making a lot of noise from the moment this problem happened (and they won't shut up, unless I poweroff or disable the bumblebee daemon). The command journalctl also does not show anything.

The system freeze happens right after startx spawned:

(==) Using system config directory "/usr/share/X11/xorg.conf.d" 

Below the line I see a non-blinking cursor. I also checked the Xorg log and it was empty.

What I've tried:

  • Format partitions and reinstall Arch from scratch
  • Setting some intel GPU configuration options (see this wiki page)
  • Adding i915.preliminary_hw_support=1 to boot options (I have a skylake CPU).
  • Turn off bumblebee daemon: fans stopped making noise and startx said 'failed to set IOPL' (probably because I had no xorg.conf file)

System information:

  • CPU: Intel Core i7 6700hq
  • Dedicated GPU: Nvidia 960m
  • I installed Bumblebee

If you need more information just ask ;)

0

I solved the problem, it appears to be related to both bumblebee and the Nvidia driver. See also this Bumblebee issue.

When Bumblebee wants to turn off the Nvidia card, it will try to run rmmod nvidia. But when I run this command Arch says it cannot unload this module because it is used by nvidia_modeset. Apparently, this new module was added recently to the Nvidia driver and causes Bumblebee to lock up the system when starting startx (because he cannot turn off the Nvidia card).

So currently, there is no solution, but when Bumblebee 4.0 releases there probably will be one.

  • Hi @Wouter92 can you tell me how did you fix the issue please? I have the same problem. Thanks – Glats Jun 1 '17 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.