3

I installed VirtualBox, in the first run i got this warning:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (3.10.0-327.4.4.el7.x86_64) or it failed to load. Please recompile the kernel module and install it by sudo /sbin/rcvboxdrv setup

After launching thist command i got:

sudo /sbin/rcvboxdrv

setup Bad argument setup

I tried another way

/etc/init.d/vboxdrv setup

bash: /etc/init.d/vboxdrv: No such file or directory

Last way that i tried

/usr/lib/virtualbox/boxdrv.sh setup

Stopping VirtualBox kernel modules [ OK ]

Uninstalling old VirtualBox DKMS kernel modules [ OK ]

Removing old VirtualBox pci kernel module [ OK ]

Removing old VirtualBox netadp kernel module [ OK ]

Removing old VirtualBox netflt kernel module [ OK ]

Removing old VirtualBox kernel module [ OK ]

Trying to register the VirtualBox kernel modules using DKMSdepmod: ... Some Warnings ... [ OK ]

Starting VirtualBox kernel modules [FAILED]

What can i try?

13

I hit the same issue today after upgrading to 5.0.14 (I am on Ubuntu 15.10, using the official Virtualbox apt repo)

I fixed it with:

sudo /usr/lib/virtualbox/vboxdrv.sh setup
  • Thanks for the answer, over several systems it was enough. Little note, in one case i needed to disable the 'Secure Boot' feature using Bios. – Hoper Jan 22 '16 at 8:30
  • I wonder why Oracle doesn't either do this for you (it seems to be required after every kernel upgrade) or at least suggest you run this manually instead of something which produces an error? – user13757 Feb 23 '16 at 20:38
  • 1
    disabled secure boot on bios setup solved my problem – Velu Aug 31 '16 at 18:15
0

You can try new installation media (a new OS). Despite Oracle owning it, I have found that even relatively new versions of Oracle Linux are not always compatible with relatively new versions of Oracle Virtualbox.

  • I found the solution, the problem was the "Secure Boot" feature. Disabling it in boot options fixed this issue. – Hoper Jan 18 '16 at 9:02

protected by chaos Jan 22 '16 at 11:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.