1

A proxy server was added using export http://link:port/.

I try to ping google.com and there is no response, the DNS is able to resolve an IP. wget of google.com works.

routes:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.123.0   *               255.255.255.0   U     0      0        0 eth0
link-local      *               255.255.0.0     U     1002   0        0 eth0
default         192.168.123.1   0.0.0.0         UG    0      0        0 eth0

ip tables:

:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [21:2344]
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited

any ideas?

1

google and most other publicly accessed sites are configured to NOT RESPOND to ICMP requests, as it is an attack vector for denial of service type of attacks. But wget is a web browser for all intents and purposes. Hence the website will respond to http and https requests, and probably nothing else. And there is nothing you can do about it.

| improve this answer | |
  • 2
    Google does answer to ping, your answer is not related to question. (Unless they select certain countries where they block it, but in all western that I've tried it has worked.) – D.S Jan 14 '16 at 23:01
0

As it seems, the probes have most likely been lost on the way out (or the replies haven't been accepted back in somewhere en route). I have checked the layout, and everything works just fine, even ICMP.

I've even managed to ping a remote host even after deleting the rule handling ICMP.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.