1

After upgrading to OpenRC 0.20 the system fails to boot properly:

mounted into runlelevel unknown (kernel 3.17.1)

The / partition is mounted read-only

/dev/sda3 on / type ext4 (ro, realtime, data=ordered)

so I did the following:

# mount / -o remount,rw

.. whch worked, after that I did

# mount -a

which mounted my /dev/sda4 (/home)

But any service I try to start gets me a segfault, e.g.

# service root start
Segmentation fault 

I am running openrc 0.20 which seems to have been installed yesterday in my latest emerge world.

2
  • What is dmesg showing ?
    – cesar
    Jan 14, 2016 at 19:13
  • @Iddo please do not add "SOLVED" to the question title. You can indicate the problem is solved by clicking the checkmark next to the answer. You self-answered so you will have to wait 2 days to accept your answer.
    – casey
    Jan 14, 2016 at 19:51

2 Answers 2

2

I would boot into single user mode (init=/bin/bash) and run revdep-rebuild, dispatch-conf and make sure your openrc configuration file is sane.

2

So here's how I solved this.

Had to run /lib/systemd/systemd-udevd to regain my /dev/fd (even though the system is openrc, not systemd)

Downgraded to openrc-0.18.4 (was running 0.20 which I emerged yesterday)

emerge -uDav @world

reboot

Seems like openrc-0.20 disagrees with me :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .