2

I think it's a driver config issue, it works in winXP(dual boot) with intel drivers. I'm debugging via serial port from another machine, which works fine.

The PC is a i5 dell Optiplex 790 running mint 17.1, works great. IT has a single serial port, via PCI on the motherboad, but linux is detecting two coms port? with two drivers (PnP & PCI)

I can TTY via "screen /ttyS0 115200" and it works, i can type and i can see the replays etc, but when I go to send anything it sends a few bytes and stops.

I'm guessing linux isn't setting up the com1 correctly? I've google'd it but I can't find anything like this.

Thanks for any help. Cheers Ben.

See command out put below from a fresh boot.

WINXP Settings: Baud: 115200 Parity: None Data Bits: 8 Stop bits: 1 Flow control: None I/O Range: 03F8-03FF IRQ: 04

Linux settings: stty -F /dev/ttyS0 115200 clocal cread cs8 -cstopb -parenb
setserial /dev/ttyS0 uart 16550A port 0x03f8 irq 4

stty -a -F /dev/ttyS0 speed 115200 baud; rows 0; columns 0; line = 0; intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ; eol2 = ; swtch = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0; -parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8 opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0 isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

dmesg | egrep -i 'serial|ttys' [ 0.904757] Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled [ 0.925235] 00:07: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A [ 0.946748] 0000:00:16.3: ttyS4 at I/O 0x30e0 (irq = 17, base_baud = 115200) is a 16550A [ 0.964931] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1 [ 0.964935] usb usb1: SerialNumber: 0000:00:1a.0 [ 0.980919] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1 [ 0.980923] usb usb2: SerialNumber: 0000:00:1d.0 [ 1.409138] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0 [ 1.653064] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0 [ 2.022446] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 [ 2.188610] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0 [ 2.355459] usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 2.355467] usb 2-1.4: SerialNumber: 00e04c000001 [ 458.078790] usb 2-1.7: New USB device strings: Mfr=3, Product=4, SerialNumber=2 [ 458.078799] usb 2-1.7: SerialNumber: 300000000002

cat /proc/tty/driver/serial serinfo:1.0 driver revision: 0: uart:16550A port:000003F8 irq:4 tx:32037 rx:12156 1: uart:unknown port:000002F8 irq:3 2: uart:unknown port:000003E8 irq:4 3: uart:unknown port:000002E8 irq:3 4: uart:16550A port:000030E0 irq:17 tx:25 rx:0 RTS|CTS|DTR|DSR|CD 5: uart:unknown port:00000000 irq:0 6: uart:unknown port:00000000 irq:0 7: uart:unknown port:00000000 irq:0 8: uart:unknown port:00000000 irq:0 9: uart:unknown port:00000000 irq:0 10: uart:unknown port:00000000 irq:0

setserial /dev/ttyS0 -a /dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4 Baud_base: 115200, close_delay: 50, divisor: 0 closing_wait: 3000 Flags: spd_normal skip_test

setserial -g /dev/ttyS[0123456789] /dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4 /dev/ttyS1, UART: unknown, Port: 0x02f8, IRQ: 3 /dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4 /dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3 /dev/ttyS4, UART: 16550A, Port: 0x30e0, IRQ: 17 /dev/ttyS5, UART: unknown, Port: 0x0000, IRQ: 0 /dev/ttyS6, UART: unknown, Port: 0x0000, IRQ: 0 /dev/ttyS7, UART: unknown, Port: 0x0000, IRQ: 0 /dev/ttyS8, UART: unknown, Port: 0x0000, IRQ: 0 /dev/ttyS9, UART: unknown, Port: 0x0000, IRQ: 0

cat /proc/tty/drivers /dev/tty /dev/tty 5 0 system:/dev/tty /dev/console /dev/console 5 1 system:console /dev/ptmx /dev/ptmx 5 2 system /dev/vc/0 /dev/vc/0 4 0 system:vtmaster rfcomm /dev/rfcomm 216 0-255 serial ttyprintk /dev/ttyprintk 5 3 console serial /dev/ttyS 4 64-111 serial pty_slave /dev/pts 136 0-1048575 pty:slave pty_master /dev/ptm 128 0-1048575 pty:master unknown /dev/tty 4 1-63 console

cat /proc/interrupts CPU0 CPU1 CPU2 CPU3
0: 15 0 0 0 IO-APIC-edge timer 1: 3 0 0 0 IO-APIC-edge i8042 4: 1731 0 0 0 IO-APIC-edge
8: 1 0 0 0 IO-APIC-edge rtc0 9: 3 0 0 0 IO-APIC-fasteoi acpi 12: 4 0 0 0 IO-APIC-edge i8042 16: 33 0 0 0 IO-APIC-fasteoi ehci_hcd:usb1 17: 2449637 0 0 0 IO-APIC-fasteoi ehci_hcd:usb2 40: 10207 0 0 44417 PCI-MSI-edge ahci 41: 2165 0 0 0 PCI-MSI-edge eth0 42: 383690 0 0 0 PCI-MSI-edge i915 43: 24 0 0 0 PCI-MSI-edge mei_me 44: 39322 0 0 0 PCI-MSI-edge snd_hda_intel NMI: 24 19 16 17 Non-maskable interrupts LOC: 387655 267084 239854 255364 Local timer interrupts SPU: 0 0 0 0 Spurious interrupts PMI: 24 19 16 17 Performance monitoring interrupts IWI: 4561 7874 4482 4784 IRQ work interrupts RTR: 2 0 0 0 APIC ICR read retries RES: 61702 57561 22920 28286 Rescheduling interrupts CAL: 510 477 638 537 Function call interrupts TLB: 6108 17079 8539 6852 TLB shootdowns TRM: 0 0 0 0 Thermal event interrupts THR: 0 0 0 0 Threshold APIC interrupts MCE: 0 0 0 0 Machine check exceptions MCP: 16 16 16 16 Machine check polls ERR: 0 MIS: 0

00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04) (prog-if 02 [16550]) Subsystem: Dell Device 04ad Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx- Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- SERR-

lspci -vs 00:16.3 00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04) (prog-if 02 [16550]) Subsystem: Dell Device 04ad Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17 I/O ports at 30e0 [size=8] Memory at e1a90000 (32-bit, non-prefetchable) [size=4K] Capabilities: [c8] Power Management version 3 Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+ Kernel driver in use: serial

------------------ UPDATE 1 ---------------------- MINT LINUX 17.3 differences - not much

cat /proc/tty/driver/serial serinfo:1.0 driver revision: 0: uart:16550A port:000003F8 irq:4 tx:0 rx:0 1: uart:unknown port:000002F8 irq:3 2: uart:unknown port:000003E8 irq:4 3: uart:unknown port:000002E8 irq:3 4: uart:16550A port:000030E0 irq:17 tx:19 rx:0 CTS|DSR|CD

cat /proc/interrupts CPU0 CPU1 CPU2 CPU3
0: 15 0 0 0 IO-APIC-edge timer 1: 3 0 0 0 IO-APIC-edge i8042 4: 3 0 0 0 IO-APIC-edge
8: 1 0 0 0 IO-APIC-edge rtc0 9: 3 0 0 0 IO-APIC-fasteoi acpi 12: 4 0 0 0 IO-APIC-edge i8042 16: 29 0 0 0 IO-APIC 16-fasteoi ehci_hcd:usb1 17: 90753 0 0 0 IO-APIC 17-fasteoi ehci_hcd:usb2 24: 4983 0 0 5263 PCI-MSI-edge 0000:00:1f.2 25: 566 0 0 0 PCI-MSI-edge eth0 26: 28220 0 0 0 PCI-MSI-edge i915 27: 25 0 0 0 PCI-MSI-edge mei_me 28: 450 0 0 0 PCI-MSI-edge snd_hda_intel NMI: 6 6 5 5 Non-maskable interrupts LOC: 101643 61501 60543 57145 Local timer interrupts SPU: 0 0 0 0 Spurious interrupts PMI: 6 6 5 5 Performance monitoring interrupts IWI: 0 0 0 0 IRQ work interrupts RTR: 2 0 0 0 APIC ICR read retries RES: 6635 5255 3448 3592 Rescheduling interrupts CAL: 699 646 553 615 Function call interrupts TLB: 3859 4185 2959 3659 TLB shootdowns TRM: 0 0 0 0 Thermal event interrupts THR: 0 0 0 0 Threshold APIC interrupts MCE: 0 0 0 0 Machine check exceptions MCP: 6 6 6 6 Machine check polls HYP: 0 0 0 0 Hypervisor callback interrupts ERR: 0 MIS: 0

lspci -vs 00:16.3 00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04) (prog-if 02 [16550]) Subsystem: Dell Device 04ad Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17 I/O ports at 30e0 [size=8] Memory at e1a90000 (32-bit, non-prefetchable) [size=4K] Capabilities: [c8] Power Management version 3 Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+ Kernel driver in use: serial ll /sys/class/tty/ttyS[012345] lrwxrwxrwx 1 root root 0 Jan 14 17:49 /sys/class/tty/ttyS0 -> ../../devices/pnp0/00:03/tty/ttyS0/ lrwxrwxrwx 1 root root 0 Jan 14 17:49 /sys/class/tty/ttyS1 -> ../../devices/platform/serial8250/tty/ttyS1/ lrwxrwxrwx 1 root root 0 Jan 14 17:49 /sys/class/tty/ttyS2 -> ../../devices/platform/serial8250/tty/ttyS2/ lrwxrwxrwx 1 root root 0 Jan 14 17:49 /sys/class/tty/ttyS3 -> ../../devices/platform/serial8250/tty/ttyS3/ lrwxrwxrwx 1 root root 0 Jan 14 17:49 /sys/class/tty/ttyS4 -> ../../devices/pci0000:00/0000:00:16.3/tty/ttyS4/ lrwxrwxrwx 1 root root 0 Jan 14 17:49 /sys/class/tty/ttyS5 -> ../../devices/platform/serial8250/tty/ttyS5/

ll /sys/class/tty/ttyS[012345]/device/driver lrwxrwxrwx 1 root root 0 Jan 14 17:53 /sys/class/tty/ttyS0/device/driver -> ../../../bus/pnp/drivers/serial/ lrwxrwxrwx 1 root root 0 Jan 14 17:53 /sys/class/tty/ttyS1/device/driver -> ../../../bus/platform/drivers/serial8250/ lrwxrwxrwx 1 root root 0 Jan 14 17:53 /sys/class/tty/ttyS2/device/driver -> ../../../bus/platform/drivers/serial8250/ lrwxrwxrwx 1 root root 0 Jan 14 17:53 /sys/class/tty/ttyS3/device/driver -> ../../../bus/platform/drivers/serial8250/ lrwxrwxrwx 1 root root 0 Jan 14 17:53 /sys/class/tty/ttyS4/device/driver -> ../../../bus/pci/drivers/serial/ lrwxrwxrwx 1 root root 0 Jan 14 17:53 /sys/class/tty/ttyS5/device/driver -> ../../../bus/platform/drivers/serial8250/

enter code here
  • stty --all --device=/dev/ttyS0 and verify the settings (stop bits, parity, etc.) are all correct for your device? You could also try a program like minicom that has a graphical menu (of sorts) for configuring the port. – drewbenn Jan 14 '16 at 22:49
  • Hi, added windows settings and my linux settings and output. Still confused about the second com, windows doesn't show it. – Ben.M Jan 15 '16 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.