4

I have a new system with a couple of 4K monitors with G-Sync support (Acer XB280HK), and a card capable of driving them (Geforce GTK 970).

I have the Nvidia proprietary driver installed, version 352.63 to be specific.

My OS is Ubuntu, but I'm running the awesomewm window manager rather than Unity. For the purposes of this post I've disabled compton, which I usually use as a compositor. For the purposes of this post I have also unplugged one of the two monitors, just to rule out it being an issue with multiple screens.

I want to get G-Sync working for video playback and games.

Video playback

Currently I see obvious tearing while playing a video both windowed and fullscreen (with mplayer -fs video.mp4). mplayer is choosing the vdpau output method, but setting this to gl doesn't make any obvious difference -- the tearing is still there, at any rate.

I've also tried passing --vo=gl:swapinterval=0:yuv=6 to mplayer, as suggested in this forum post, and this doesn't seem to have any effect.

Games

I'm testing right now in Half-Life 2 Episode 1, and restarting the game each time I change a setting in the nvidia-settings config panel. I've tried some reboots too, though not for every combination of settings.

The game is set to full screen, native resolution. (That means the resolution does not change when the game launches and quits.) The v-sync option in the game's own settings has an effect in that it limits the frame rate to 60 (normally it is much higher). Interestingly, switching this on and off does not affect the tearing, or at least I see tearing with it in either setting. This is the same whether "Sync to VBlank" is enabled or not in nvidia-settings, too.

Settings

I've tried tweaking various settings in the nvidia-settings GUI. The main contenders appear in the "X Server XVideo Settings" and "OpenGL Settings" tabs.

In the former there is "sync to this display device" which can either be auto or the one still-plugged-in screen. It's currently auto, though I've tried specifying the screen too.

In the latter there are checkboxes for "Sync to VBlank", "Allow Flipping", "Allow G-SYNC" and "Enable the G-SYNC Visual Indicator". Obviously I've switched on "Allow G-SYNC", and I've switched on the indicator too, but have never seen it (what would it look like? I've seen nothing obvious -- more at the bottom). I've tried all four combinations of "Sync to VBlank" and "Allow Flipping", but I see no difference in the game or in video playback.

My monitors also have a feature that draws the current refresh rate as a little red bar in the corner of the screen. I've switched that on but never seen anything but 60 on it.

Any ideas?

With compositor on

With the compositor (compton) switched on, as long as I run it after switching on "Enable G-SYNC Visual Indicator", and as long as "Allow Flipping" is switched on, I see the word "NORMAL" on the screen. This sometimes flickers off and on when loading programs. The frame rate still stays steady at 60, and whether I see tearing (in video, games, and just on the desktop eg when scrolling Firefox) depends on whether I check "Sync to VBlank".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.