1

I have successfully installed Kali 2.0 on my Macbook Pro retina 2015 model running El Cap via dual boot. I do have some experience with Ubuntu etc, and thought I'd try Kali for multiple reasons.

Now, I thought everything worked perfectly, until I noticed there was no WiFi icon in the menu bar. Well, no problem I thought initially. I just grabbed an ethernet cable and connected to my home network without problems. I downloaded the appropriate driver for my network adapter, the Broadcom 4360. However, when I attempted to install the package, the terminal spat out the error message that the package dkms was not installed. Okay great, that can also be installed manually I thought. After trying that, I got yet another error module init tools not installed. Then I figured that this is not just a problem with my Broadcom thingy, but perhaps with my Kali install.

Things I tried:

Error file is here, I believe the most pressing error is the last one (they are separated by !!!!'s): http://www.megafileupload.com/egdH/errors.

  • Please post the exact error messages you're getting. Don't just say "there are errors"; these errors are crucial in figuring out what's going wrong. We don't have a crystal ball. – Wouter Verhelst Jan 13 '16 at 12:41
  • @WouterVerhelst I added them, really hope you can help me :) – coderjoe Jan 14 '16 at 14:04
  • Dayum, I fixed it. Well, I don't know what I did differently this time, but it's working now. Thanks for taking the time y'all. – coderjoe Jan 14 '16 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.