2

I have setup ldap server successfully and everything works find. However, i cannot access the server with 'anonymous' bind, which according to every google search it should be.

When I execute;

# ldapsearch -x -H ldap://localhost -b dc=example,dc=com

output says;

# result: 50 Insufficient access

Note: the only ACL exist is;

olcAccess: {0}to * by self write by anonymous auth by * none

Does this prove that the server is not compiler or configured to work with anonymous bind? And if so, what is the best way to enable it?

0

Someone from ServerFault answered this question. https://serverfault.com/questions/748758/enable-anonymous-bind-in-openldap/748904#748904

Issue was the configured ACL. The line of by * none block most anonymous actions. Once get rid of that server allows to perform anonymous ldapsearch actions, proving, by default, openldap support anonymous bind.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.