2

I'm running a virtual machine from qemu with the -curses flag in order to view it over a slow ssh connection.

Everything works well enough, but the terminal window that I have to interact with the guest machine is small (80x80 characters? just a guess) and the extra space is just letterboxed in my terminal program.

Is there a way to have the qemu curses interface expand to make better use of the available space?

I'm using qemu-system-i386 version 2.4.1.

1

According to the qemu wiki, you can use a higher-resolution display using the -vga std option:

-vga type

Select type of VGA card to emulate. Valid values for type are

cirrus

Cirrus Logic GD5446 Video card. All Windows versions starting from Windows 95 should recognize and use this graphic card. For optimal performances, use 16 bit color depth in the guest and the host OS. (This one is the default)

std

Standard VGA card with Bochs VBE extensions. If your guest OS supports the VESA 2.0 VBE extensions (e.g. Windows XP) and if you want to use high resolution modes (>= 1280x1024x16) then you should use this option.

  • Thank you for the answer. Even with -vga std set the curses terminal is unchanged on reboot. I also tried setting the rows/columns with stty to no avail. – ctag Jan 13 '16 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.