0

I ran dd if=/dev/zero of=/dev/sdc count=2048 on the pen drive.

I can see the pen drive in the lsusb output, and dmesg says that it is 8 GB in size, but when I use, say, cfdisk, it says that there is 1 MB of free space. (I think that corresponds to some kind of EFI partition that Rufus made.)

There is only a /dev/sdc device corresponding to the pen drive.

Please tell me if there is any output you'd like to see.

Update: I ran dd again, but without the count option, and the drive now shows up as being 2 GB in size (and dd threw a "no space left" error). I tried writing a partition table to it with cfdisk. It seemingly worked, but there still is no corresponding /dev/sdc1.

I then used mkfs.vfat on it, and it now shows up as 7.5 GB Removable Media in Dolphin. But cfdisk now says that it is just 2 GB of free space. I can now create files on the pen drive, but will this die suddenly? I want to do a Windows installation using it.

Also, there is now a bunch of "loop devices" in Dolphin. What's going on?

1 Answer 1

0

I think the problem is with the misinterpretation of blocksize in different environments. So, you can set it yourself.

You can try

dd if=/"file" of=/"out file" bs=2048

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .