11

After having installed the proprietary Nvidia driver on Debian Jessie in order to play Steam games (which I now can), I can't change the brightness at all, it is stuck at the maximum and is irritating my eyes at night. I have already tried all of the solutions in the Debian wiki

such as adding the line: Option "RegistryDwords" "EnableBrightnessControl=1;" to /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/20-nvidia.conf

but that has not worked, even though in the Debian forums it seems to work (marked solved):

xbacklight does not work at all, and I don't know what to do anymore. I will post any outputs for whatever terminal commands, please help.

5
  • 2
    How about xrandr --output LVDS1 --brightness 0.4 (put your display instead of lvds1 if needed)?
    – jimmij
    Jan 11, 2016 at 0:33
  • 1
    xrandr --output LVDS-0 --brightness 0.2 works! It doesn't seem to change the brightness at the hardware level, but it will save my eyes! Thanks to user jimmij!
    – anon76
    Jan 11, 2016 at 0:44
  • 1
    Yes, this is software change, and echo 2 > /sys/class/backlight/acpi_video0/brightness doesn't work? (again change acpi_video0 to your device like intel_backlight etc.).
    – jimmij
    Jan 11, 2016 at 0:54
  • When I do sudo echo 2 > /sys/class/backlight/asus-nb-wmi/brightness I get: bash: /sys/class/backlight/asus-nb-wmi/brightness: Permission denied
    – anon76
    Jan 11, 2016 at 1:25
  • Try running sudo -s then the eco. Sudo doesn't work over piped echos in the way described. You need to do echo "moo" | sudo tee /patch/to/file.txt
    – Torxed
    Jan 11, 2016 at 8:44

3 Answers 3

5

After adding the following line in your X device configuration

Option  "RegistryDwords"  "EnableBrightnessControl=1"

You can use the software xbacklight to adjust the brightness:

xbacklight -set 60
2
  • Added that option to my /usr/share/X11/xorg.conf.d/20-nvidia.conf in Debian 8 and now everything works normally in KDE
    – LatinSuD
    Jul 25, 2017 at 20:17
  • Seems KDE is more forgiving than gnome, FWIW askubuntu.com/a/1152763/20972
    – rogerdpack
    Jun 21, 2019 at 4:35
2

Complementing @semente answer:

xbacklight +10
xbacklight -10

increase and decrease the backlight in steps of 10%. They can be associated to keys with xbindkeys by following the instructions here. Below is sample of the .xbindkeysrc with this commands associated to the Windows + F5 and Windows + F6 keys:

"xbacklight +10"
 Mod4 + F6

"xbacklight -10"
 Mod4 + F5
1

I followed this tutorial to install NVidia driver for linux from NVidia:

http://allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-debian-8/2/

and now I have NVIDIA X Server Settings GUI which can be launched from applications drawer, then I go to GPU 0 --> CRT-0 --> Color Correction and I'm able to set brightness to negative value.

enter image description here

2
  • 4
    This doesn't change the backlight brightness. Feb 15, 2017 at 3:04
  • thanks for this color correction settings, i didn't know that @TimRichardson, you could use xrandr --output HDMI-0 --brightness 0.7 change the HDMI-0 with your monitor
    – haidarvm
    Dec 17, 2020 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.