I would like to play m3u with vlc on raspberry pi using ssh (I don't have any screen to connect to the pi).
I tried the following answer:
Program run in SSH accessing pulseaudio on the machine where it runs
But it didn't helped: I still get "PulseAudio server connection failure: Connection refused" Thank You

  • I guess raspebby is in server mode, so fetching nautilus PID will be of no help.
    – Archemar
    Jan 10, 2016 at 10:01
  • exactly, i listed processus with ps -x and I chose an other processus
    – JuliusII
    Jan 10, 2016 at 10:20

1 Answer 1


Finally Find a way.. I starded vlc with a ssh -X session. Then I selected ALSA audio device instead of pulseaudio and I saved the configuration.
then I launched "cvlc http://mystream.m3u &". Finally I ctrl+D and closed the window. Sound works perfectly

  • now I'm trying to do it with a .sh file .
    – JuliusII
    Jan 10, 2016 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.