1

thanks for looking at this question. I have seen several other questions about eOS login loops--none solved my problem, including upgrading the kernel, deleting .Xauthority, etc.

Last night I changed my password. This morning, I woke up and tried to login into my eOS Freya desktop, and it just took me back to the login screen. It looked like it was about to log me in, but it didn't. I tried several different methods of fixing it, and they all worked temporarily, but stopped working after I rebooted my computer.

Eventually I figured out that it was only when I accessed tty1, logged in, and decrypted my filesystem with ecryptfs-mount-private and then logged in, would it work. However, it was also gone by the next reboot.

My password for decryption is different from my login password--up until last night, they were the same.

Is it possible that Linux expects the credentials for login and decryption to be the same? If so, what can I do to fix this? It is a minor inconvenience.

Some other information that may be of importance, I am not sure: - I am running eOS Freya - I have a conky, terminal, and sticky notes starting when I log in - I replaced pantheon-terminal with gnome-terminal - I replaced Gala with Fluxbox - The reason I am asking this on unix.stackexchange and not elementaryos.stackexchange is because I believe this is a universal Unix/Linux problem, and NOT solely attributed to eOS. - I have not really fooled around with configuration files much.

Thanks in advance for your help!

  • It is not an universal Linux problem, it is most likely the display manager's/init script's fault. Doesn't it mount /home before firing lightdm up? – sikerbela Jan 10 '16 at 1:33
  • @sikerbela is there a way I can check? – Joseph Farah Jan 10 '16 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.