Trying to install a linux distro (CentOS/Ubuntu) on ASUS ZenBook Pro UX501VW-DS71T fails so far. I've used bootable usb, created by pendrive/unetbootin from range of iso files (centos-minimal/ubuntu-desktop/ubuntu-live).

In CentOS setup menu, I have tried troubleshooting & selecting basic graphic mode. I also tried text mode. Booting process stops at some point and dracut terminal appears.

I have copied dmesg, journalctl, rdsosreport.

With ubuntu-live, it brings up the busybox built-in shell with the following prompt:

(initramfs) Unable to find a medium containing a live file system

Any idea could help.

  • What the media you are using for the DVD installation is not supported, or faulty. External drive? Jan 9, 2016 at 3:08
  • I checked all images I had, and created bootable USB with unetbootin and pendrive. Please check the rdsosreport and comment.
    – Saeed
    Jan 9, 2016 at 13:43

2 Answers 2



Installing Linux is easy, requires no BIOS reconfig/secure boot nonsense. I've tested tested with both 14.04 LTS and 15.10.

First build an Ubuntu install disk on a USB thumb drive (either 15.10 or 14.04 LTS). Boot into windows, use Disk Management utility to shrink Windows partition, reboot and boot from USB by holding F2 on powerup. Go to last tab and boot override using the USB drive containing ubuntu.

UBUNTU 15.10

Ubuntu 15.10 works out of the box with no problems except trackpad lacks two finger scroll. Sound, video, brightness, suspend, wifi, ethernet, all appear to work. I highly recommend using 15.10 if you want a super painless install and the latest Ubuntu software. The trackpad can be fixed -- just haven't had the chance to mess around with it yet.


I needed to use Ubuntu 14.04.3 LTS, and you can get it to work just as well as 15.10, but just a little more work. You'll find when trying to install from USB, it hangs. It can take multiple reboots to eventually get the installer CD to boot. Once you get through -- install ubuntu on the partition you created. Unplug the USB and reboot and you will see the GRUB menu. You'll be able to boot into Ubuntu -- however, this is not a safe configuration and after about 30 seconds, the cool fan will turn on max speed and never stop (which is super loud and bad for your fan!) . This is because the drivers are dated in the 3.19 kernel and you need 4.2 as well as additional X server updates. Connect to wifi and install the Ubuntu LTSEnablement stack that will give you the same kernel and drivers as Ubuntu 15.10. The USB Ethernet dongle provided by Asus also works if you prefer wired connection. To install type the follow commands:

sudo apt-get update

sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily)

Reboot and things will come up ok.


Note that in both 15.10 as well as 14.04.3 with the LTSEnablement stack, the video card being used is the low power Intel onboard GPU. There's nothing wrong with using this card and it's adequate for most appilcations, but if you want to use the high performance nVidia GeForce GTX 960M for things like gaming, scientific computing, or 3d graphics, you got to install the proprietary nVidia driver. It works great, but I found that I can't seem to switch back to the Intel card without purging the nVidia driver which is unfortunate. Use this link for guidance: https://askubuntu.com/questions/658040/ubuntu-14-04-nvidia-drivers-for-geforce-gtx-960m

4K SUPPORT: Both Ubuntu 14.04 and 15.10 support 4K displays. Go to Settings->Display and set "Scale for Menu and Title Bars" to 2. This fixes most apparent issues immediately. Many apps like Rhythmbox and Firefox are designed to handle 4K, but many are not like Gimp. Many programs have command line options to put them into High DPI mode for high res displays but this is on an a per-app or per-toolkit (e.g. Gtk, Qt) basis. Overall I've found it tolerable but find myself hopping down to 1920x1080 when working with tools that have not adapted. I have to say Windows does a better job with 4K support.

OTHER ISSUES: -Can't control brightness in 14.04 from keyboard shortcuts, but can from settings->brightness. -Still need to find instructions get two finger scroll on touch pad, they're out there but couldn't get it to work yet. It might be fixed in the 4.4 kernel.

  • Thank you for response. I'm familiar with installing a dual boot system, the question is about ASUS ZenBook Pro UX501VW-DS71T that you didn't mention in your response. It boot into USB but does not even bring up Ubuntu live. Any comment?
    – Saeed
    Jan 18, 2016 at 18:47
  • I have the exact same model (UX501VW) and bought it only a week ago. Ubuntu 15.10 should boot from USB reliably out of the box. 14.04 may take several reboots until it comes up into either live usb mode or install mode depending on your choice. Either you installation media is bad or there's some defect in your machine.
    – mas
    Jan 19, 2016 at 8:31
  • I wish someone could explain why shrinking the windows partition would help ubuntu live boot! I assumed live boot USB images would load themselves into memory, and wouldn't touch disks. Anyway, ubuntu 15.10 is installed (I chose to remove factory windows that I would never use)
    – Saeed
    Jan 20, 2016 at 21:30
  • You don't need to shrink the partition to run the 15.10 live cd. However, if you want to install ubuntu to the hard disk, you need to shrink the windows partition. For some reason, the windows partitions are not visible through the Ubuntu installer nor to gparted on the live cd, so you have to go into windows, shrink the partition to create unpartioned space, go back into the ubuntu installer, and install onto the unpartitioned space. if you can't get that workflow to work, either it's your install media or a physical problem.
    – mas
    Jan 21, 2016 at 4:00

This happens when using a bootable usb3 stick in a usb3 port. The solution is either to

  • put the usb3 stick in a usb2 port or
  • create a bootable usb2 stick and try again.

Since the UX501VW doesn't have a usb3 port the second option works best.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .