5

I am currently using a macbook pro but the operating system is debian 8.2 not os x

I am using a macbook pro but there's this one device that's just draining a lot of power. This USB device: Card Reader (Apple)

 32.5 W    100.0%                      Device         USB device: Card Reader (Apple)
  2.60 W    100.0%                      Device         Radio device: btusb
  209 mW     19.7 pkts/s                Device         Network interface: wlan0 (wl)

This device really drains my battery, I noticed that my laptop wouldn't even get 2 hours when not plugged in, I installed powertop. Made all the recommended changes but this device, I can't find out how to disable it. I don't even use that reader and forgot that it was there.

I configured all my devices to use limited power in my rc.local

echo '0' > '/proc/sys/kernel/nmi_watchdog'
echo 'min_power' > '/sys/class/scsi_host/host0/link_power_management_policy'
echo '1' > '/sys/module/snd_hda_intel/parameters/power_save'
echo '1500' > '/proc/sys/vm/dirty_writeback_centisecs'
echo 'auto' > '/sys/bus/usb/devices/2-4/power/control'
echo 'auto' > '/sys/bus/usb/devices/1-12/power/control'
echo 'auto' > '/sys/bus/usb/devices/1-8.3/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.3/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:01:00.1/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1c.3/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1c.4/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1c.2/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1c.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1b.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:16.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:14.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:01.1/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:01.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:01:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:08:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:07:06.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:07:05.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:07:04.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:07:03.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:07:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:06:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:05:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:04:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:03:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.0/power/control'

How can I get this device to act sanely or disable it completely because I haven't used it.

3

In the Power Management for USB, kernel documentation, you will find a summary of poweroff pre-requisite settings relative to a port device:

echo 0 > power/pm_qos_no_power_off
echo 0 > peer/power/pm_qos_no_power_off # if it exists
echo auto > power/control # this is the default value
echo auto > <child>/power/control
echo 1 > <child>/power/persist # this is the default value

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.