4

I've looked through other posts with similar issues but so far to no avail. I'm running dual boot with Windows 7 and Ubuntu 15.10 and although the Ethernet connection works on Windows, when I boot Ubuntu it works for a few seconds and then the connection drops. I don't get any notification saying I've been disconnected and the symbol remains the up/down arrows. When I try pinging to a host like Google no host is found. I've disabled Wi-Fi on Ubuntu and tried unplugging/replugging and I get the same issue with working for a few seconds then losing connection.

When I run ifconfig -a I get

enp2s0    Link encap:Ethernet  HWaddr dc:0e:a1:f5:60:20  
          inet addr:10.61.3.103  Bcast:10.61.3.255  Mask:255.255.255.0
          inet6 addr: fe80::de0e:a1ff:fef5:6020/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:309 errors:0 dropped:0 overruns:0 frame:0
          TX packets:109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:42594 (42.5 KB)  TX bytes:13900 (13.9 KB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:246 errors:0 dropped:0 overruns:0 frame:0
          TX packets:246 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:22223 (22.2 KB)  TX bytes:22223 (22.2 KB)

wlp3s0    Link encap:Ethernet  HWaddr 9c:4e:36:17:1f:44  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

And when I run netstat -rn I get

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.61.3.1       0.0.0.0         UG        0 0          0 enp2s0
10.61.3.0       0.0.0.0         255.255.255.0   U         0 0          0 enp2s0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 enp2s0

I also tried running sudo arp-scan -I enp2s0 -l to look for duplicate addresses and found none.

I'm still very new to Linux and some network terminologies but any help would be appreciated.

Also to note that the Wi-Fi connection works just fine. It's just the wired connection that is having problems.

  • What is your ethernet card? (lspci). Any relevant log messages? – vonbrand Jan 8 '16 at 0:13
  • If you run tcpdump after things break, do you see any traffic on the interface? – Mark Plotnick Jan 8 '16 at 2:37
  • Ethernet controller is Qualcomm Atheros AR8161 Gigabit Ethernet. No log messages when it breaks. I get an Operation not permitted message when I use tcpdump – Bert Jan 8 '16 at 3:09
  • My bad I didn't run it with sudo, I repeatedly get "22:15:52.977713 ARP, Request who-has 10.61.3.1 tell 10.61.3.103, length 28" when I run tcpdump. – Bert Jan 8 '16 at 3:17
3

Try setting your Wired MTU to something really high (like >8192) - I know there was a bug for some Atheros cards (especially AR8161). This is a temporary solution though, and doesn't fix the issue, just postpones it. I am working on a patch for Ubuntu 16.04 - will let you know if fixed :)

  • 1
    Setting it to 8192 bytes worked for me! At first I cannot believe it---it worked like a charm! You might want to point out to novices how to set MTU (go to Network Manager -> Edit Connections -> Ethernet -> MTU) – Xin Aug 29 '16 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.