0

Please, help...

I have a 'EPPOS Model EPT-58H' thermal printer. When I plugin via usb, it detected as /dev/usb/lp0 with ls -l /dev command. Then I run echo "sometext" > /dev/usb/lp0 in terminal to check if my printer can actually print from my notebook, but nothing happened. The command itself seems succesfully executed, but my printer didn't print that sometext.

Then I tried to run ls -l /dev/ again, my usb dissapear. It will show up again if I restart my printer.

Then I check with dmesg command, it shows that my printer didn't properly make connection with my notebook, it says ehci-pci error -32 or something like that.

I tried to install the driver from CUPS web on localhost:631, but I don't have any idea which one should works, you know, 'EPPOS' didn't even shown in the driver list.

Any idea how to solve this? I've already search anywhere no clues about my printer issue. Note, I did this , and this (and the link inside, except using wine solution, didn't even want to)

Tried on 3 Laptop (2 Ubuntu 14.04, 1 Mac OS X), 1 PC with Ubuntu 14.04, 1 mini PC with Xubuntu. The result are all the same.

It only works with Windows (obviously, it has its driver for Windows), and a Laptop using FreeBSD.

It's almost 2 months now since I ask this question in AU and didn't have solution for this. Anyone?

0

I give up trying this. It is not working either with 16.04 LTS which is using 4.4 linux kernel.

And on Windows 8.1 with proper driver ended with failed too.

Here I am finally using BSD (OpenBSD, NetBSD, and another BSD-based) succesfully working. On BSD, it is mounted as ulpt0.

It's a dead end trying on other Linux (Debian-based, Arch, RedHat, blabla).

So, at the end I use BSD to work this out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.