2

I think I seriously messed things up on my EC2 instance which I'm currently hacking on. I tried to install some rpmfusion repository from which to install FFMPEG, but it broke things and I wasn't able to do any updates or install anything.

So, I ran a pretty straightforward rm command: rm /etc/yum.repos.d/rpmfusion-*. I think this really messed things up, though, as I can't seem to find rpmbuild which I need to install FFMPEG.

Can anyone help me recover from this? I don't have access to the EC2 control panel, otherwise I'd just up another instance and start over. Can anyone instruct me on how to simply install FFMPEG on a CentOS-like OS?

3
  • I am just curious why do you want to install ffmpeg on a server hosted in cloud? Commented Nov 25, 2011 at 22:07
  • Probably going to use ffmpeg as a base to stream video - like using it with ffserver.
    – Rilindo
    Commented Nov 25, 2011 at 23:29
  • 1
    Advice to avoid this particular problem in the future: keep /etc under version control. etckeeper makes this totally painless, see this article or more generally etckeeper+centos. Commented Nov 26, 2011 at 0:44

2 Answers 2

1

You can reload the REPO RPMS here:

http://rpmfusion.org/Configuration

You probably want to find the version that matches what you have installed and do:

yum reinstall packagename
0

To create a repo file for base package

  1. vim /etc/yum.repos.d/Centos-Base.repo
  2. You have to change Centos-Base.repo like this:

    [base]
    name=CentOS-$releasever – Base
    #mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
    baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
    
  3. save file :wq

  4. Now try installing/re-installing any software

    yum reinstall ekiga
    

    Output

    Installed:
    ekiga.x86_64 0:4.0.1-4.el7  
    

if this installs you are all set.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .